Mystery Fuse - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th July 2004, 06:00 PM   #1
honsten is offline honsten  United Kingdom
diyAudio Member
 
Join Date: Feb 2004
Location: london
Default Mystery Fuse

hi, my arcam's left channel is er,not working-it just makes a loud crakle when turned up.
i asked in my regular hi fi shop who are excellent and i explained the problem. the guy told me to open the machine and to replace the fuse for the left output (channel).

i got home,opened the amp and i cant find any obvious fuse in the output stage after many hours of looking. please help as im missing my music!
  Reply With Quote
Old 25th July 2004, 08:05 PM   #2
diyAudio Member
 
Join Date: Jul 2003
Location: Nottingham, England
There are two possibilities:

1. The guy in the shop has special powers that enable him to accurately diagnose the probem without even seeing the amplifier.

2. He doesn't know what he's talking about.



IMO the problem you describe does not indicate a blown fuse but then I'm not a full qualified hi-fi salesman so I could be wrong.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuse housing melting but fuse not blowing, ppi amp rawadia Car Audio 21 2nd August 2008 10:39 AM
little 6.5 mystery ... oface Full Range 6 4th November 2007 11:20 PM
Why main fuse and not rail fuse? digital desire Solid State 10 3rd December 2006 08:07 PM
amp rating for fuse and fuse holder? riotubes Parts 5 27th August 2006 03:10 AM
Mystery Amp Rating on Fuse DreadPirate Solid State 5 24th April 2006 01:10 PM


New To Site? Need Help?

All times are GMT. The time now is 12:00 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2