i guess... - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd May 2002, 07:32 PM   #1
diyAudio Member
 
Mr. Triatic's Avatar
 
Join Date: Feb 2002
Location: SWE EU
Default i guess...

... that you can use BD711/712 or BD911/912 with good results, i use them as output transistors in one of my amps..works really well.. check the data, they´ll survive 100V across...
/L.
__________________
www.joddla.net/audio/
  Reply With Quote
Old 22nd May 2002, 07:33 PM   #2
diyAudio Member
 
Mr. Triatic's Avatar
 
Join Date: Feb 2002
Location: SWE EU
Default sorry, wrong place to post...

..i guess that i chose wrong button...
once again, sorry!
__________________
www.joddla.net/audio/
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Introductions I guess anatech Introductions 8 2nd March 2009 04:06 AM
Guess, what is it? Wavebourn Everything Else 12 20th October 2008 08:40 PM
I'm new here I guess navinjohnson Introductions 3 25th September 2007 08:38 PM
Guess who's back... SkinnyBoy Introductions 18 31st May 2004 02:53 PM


New To Site? Need Help?

All times are GMT. The time now is 09:29 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2