Spectro Acoustics SR200 amp - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th June 2004, 09:07 AM   #1
ekaerin is offline ekaerin  Sweden
diyAudio Member
 
ekaerin's Avatar
 
Join Date: Jun 2004
Location: Stockholm
Default Spectro Acoustics SR200 amp

Hi everybody,

I have an old Spectro Acoustics SR 200 Poweramp. When I bought it
it was pretty trashed with some bad repairwork done to it.
I fixed it up, changed all outputs, drivers, "emitter" resistors, supply caps
and bridge.
It works nice but have some audible distortion at low levels.
I have tried the trimpot but it didn't help.

Does anyone have the schematics for this amp ?

Even if I don't use it to often it would be nice to know more about it
and see if I can get rid of the dist.

/ Regards / Mattias
  Reply With Quote
Old 11th June 2004, 08:42 AM   #2
djk is offline djk
diyAudio Member
 
djk's Avatar
 
Join Date: Feb 2001
Location: USA
Gave my schematics away about ten years ago on that one.

The basic topology is the same as the HK Citation 12

http://www.passdiy.com/pdf/citation.pdf

The Spectro runs on a higher voltage, about ±67V, and has four outputs per channel, RCA 1B05 (obsolete, use MJ15022/24), use MJE15030/31 for the drivers.

The VAS was a house number TO5 from RCA, the industry standard numbers are 2N3440/2N5415, and the diff pair MPSA06/A56 (I can't remember if the diff pair was NPN or PNP, I've listed both. The VAS would be the opposite polarity).

The bias circuit is a little different, you will have to draw it out.

Change the cap in the feedback loop, change the bootstrap cap.

If the bias doesn't work right, the bootstrap will not work right.

The reverse is also true.

There was a factory mod involving the inputs and grounding for same, that was for hum.
  Reply With Quote
Old 11th June 2004, 09:05 AM   #3
ekaerin is offline ekaerin  Sweden
diyAudio Member
 
ekaerin's Avatar
 
Join Date: Jun 2004
Location: Stockholm
Default djk thanx..

.... Yes the outputs were marked SPECTRO and some MJxxxx No.
I do not have it here but I know I put in the same types except for the
drivers which are japs now.
Intresting points about the bootstrap and bias. I wiil go back and try to
draw a schematic as you suggested and do some measurements.
(Just called my friend who keeps it in his studio to bring it home today)

Thanks again for your input / Mattias
  Reply With Quote
Old 29th November 2008, 01:14 AM   #4
Ekus is offline Ekus  Sweden
diyAudio Member
 
Join Date: Aug 2008
Send a message via MSN to Ekus
Hello, My name is Henrik and i'm also live in sweden .. So i will write swedish now because my english isn't very good.

Det är så att jag tycker väldigt mycket om ljud och spelar som dj ibland som ett Fritids intresse För några år sedan köpte jag på mig en rack med Spectro Acoustics Radio, förförstärkare, slutsteg och equlaizer .. en dag när jag spelade lite musik på "normal" volym , inget överdrivet med andra ord. Så gick ena kanalen helt plötsligt :S har haft in den hos en bekant som lagar elprylar, han konstaterade vad det var för fel men hittade inga reservdelar. Så nu är min fråga om du vet vart man kan hitta reservdelar passande till detta slutsteg ? Väldigt tacksam för svar Mvh Henke
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fm acoustics ben goh Solid State 29 28th May 2012 05:49 PM
Spectro Acoustics 500 problem hatrack71 Solid State 1 2nd May 2009 11:45 AM
Need help in Acoustics! audioPT Multi-Way 13 1st December 2003 10:13 PM
Capacitor Replacement on Spectro Amp ralph-bway Solid State 2 17th October 2003 03:52 AM


New To Site? Need Help?

All times are GMT. The time now is 06:45 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2