Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

leach amp trouble shooting
leach amp trouble shooting
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th May 2004, 04:31 PM   #1
victordsouza is offline victordsouza  United Arab Emirates
diyAudio Member
 
Join Date: Sep 2003
Location: dubai
Default leach amp trouble shooting

Hi guys,

need help trouble shooting leach amp. One channel of a perfectly fine working amp blows output stage, zobel N/W blackened, r32,r33 burned, 15033 driver shorted .

amp working fine with 8 ohm . this happenned when using 4 ohm load. Power supply is capable and outputs are 2 pairs each.

any possibilty of oscillations existing with 4 ohms but not with 8 ohms

any suggestions appreciated.

Thanks

Victor
  Reply With Quote
Old 30th May 2004, 01:47 PM   #2
destroyer X is offline destroyer X  Brazil
diyAudio Member
 
destroyer X's Avatar
 
Join Date: Feb 2004
Location: Recife - Brasil Northeast
Default Yes, happens to me too!

By the way, Souza was my ancestral family name.... from holland people that came Brazil 1620 i suppose.... they gonne to states... they found the place today is called Manhattan.... they were Jews... and scape from here when Nassau Princip decides to return Holland... all Jewish goes to the place now Manhattan, and there made a community...long time ago.

My leach amplifier oscilates before a killed him, dismounted him because loose deep bass.

Put 22 pf capacitors every transistor.... all them.... from colector to base.

Good luck.

Carlos
__________________
Dx unbeatable amplifiers; https://www.youtube.com/watch?v=u4tGBiqMnzQ
  Reply With Quote
Old 30th May 2004, 04:22 PM   #3
victordsouza is offline victordsouza  United Arab Emirates
diyAudio Member
 
Join Date: Sep 2003
Location: dubai
Thanks Carlos,

I thought as much it is probably oscillating. However i thought that all bugs in this amp were sorted out .

I would like to know anyway if someone else on the forum faced the same problem.

P.S
I was thinkin all this while the dsouza name originated from the old portuguese who ruled goa and whereabouts in India.
  Reply With Quote

Reply


leach amp trouble shootingHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Leach 4.5 Trouble Shooting Help ptah Solid State 2 12th November 2007 09:06 PM
Op amp trouble shooting Bose(o) Chip Amps 13 1st April 2005 08:37 PM
Help trouble shooting Christof Tubes / Valves 11 1st September 2004 03:27 AM
need some trouble shooting help Jean Solid State 41 7th October 2002 05:53 AM
Trouble shooting help NerdMike Solid State 2 29th September 2002 01:34 AM


New To Site? Need Help?

All times are GMT. The time now is 10:00 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki