a few pics of my amp - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th May 2004, 11:45 PM   #1
Tensop is offline Tensop  Lebanon
diyAudio Member
 
Join Date: Jul 2003
Location: Chapel St.
Default a few pics of my amp

hey, finally got hold of a (crappy) kodak dc3400 digicam.. the amp is an sc480 kitamp from jaycar in vic.. specs are 0.03%THD @ 50w/8r
psu consists of 150va, 9400uF capacitance per amp, so 20,000uF and 300va in total.. sounds very nice but a bit weak in the low end
Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.
  Reply With Quote
Old 13th May 2004, 11:48 PM   #2
Tensop is offline Tensop  Lebanon
diyAudio Member
 
Join Date: Jul 2003
Location: Chapel St.
Click the image to open in full size.
  Reply With Quote
Old 14th May 2004, 05:33 AM   #3
diyAudio Member
 
li_gangyi's Avatar
 
Join Date: Jun 2003
Location: Woodlands Circle
wonderful job...wonder why it's weak on the low end...might be due to the input cap?
__________________
Kids in the back seat cause accidents...Accidents in the back seat cause kids...
  Reply With Quote
Old 14th May 2004, 06:26 AM   #4
Tensop is offline Tensop  Lebanon
diyAudio Member
 
Join Date: Jul 2003
Location: Chapel St.
Doubt its due to the capacitors, the roll off chart is only about -2dB @ 10hz
and my mistake - its actually 9400uF per rail(10,000uF when taking the pcb mounted parallel cap) so 40,000uF all up. the low frequencies are extremely clear, best i've heard from an amp yet but a bit too quiet. when i get the time i'll clean up the wiring and use some shielded inputs to the amp, to get rid of the slight high frequency interference im getting, maybe put a grounded shield around the transformers to isolate them too?
and, as a great source for mains cables i took the powersupply cable from an old AT computer case, it has an earth shield all through the inside(foil and braided wire), even had an earth lug on the end!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pinoy DiY'ers, FT1600 pics..pics dranreb&* Full Range 5 3rd November 2004 10:21 PM
Pics of my new amp Cro maniac Chip Amps 19 8th May 2004 04:20 PM
Pics of my new amp! Morse Tubes / Valves 16 21st April 2003 07:04 PM
PICS: GainClone Monoblock pics Rarkov Chip Amps 19 17th April 2003 07:37 AM


New To Site? Need Help?

All times are GMT. The time now is 02:36 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2