cracking noise in P3a - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th May 2004, 04:03 AM   #1
PetarLD is offline PetarLD  Bulgaria
diyAudio Member
 
Join Date: Feb 2004
Location: Sofia
Send a message via ICQ to PetarLD Send a message via AIM to PetarLD Send a message via MSN to PetarLD Send a message via Yahoo to PetarLD
Default cracking noise in P3a

Hello, a long time ago I build 2 P3a's. They work great still no failiers.

But I have noticed that when I try to get too much bass out of one of them, it starts to make cracking noise. I have a sine generator, and at any frequency below 70Hz it starts to crack with the same frequency except the cracking noise is coming out of the tweeter. I don't have an oscioloscope to check, but I suspect that I possibly damaged some of the transistors when I accidently soldered q9 the wrong way and all of the bc546 transistors blew up, then I checked all of the other transistors and they measured the right values, I just measured them with Ohm meter. So I got some new bc546's and I powered the amp without a heat sink, so when i touched the output transistors they burned my fingers, and I powered down immediately. I put the heat sink on and powered back again, and everyting worked fine until I noticed that cracking noise. Both amps are using exactly the same transformers and caps and everything so I am suspecting those transistors, I have 3 of each so I am going to try to replace them, even tho they measure the same resistance as the ones on the working amp, I didn't try to exchange them because it's just too much trouble. The amps are running at +/-24V DC so I am in the SAO. I am just looking for an advice and any information is greatly appreciated. Thank you very much.

Petar
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cracking sound from amp - help Brit01 Solid State 5 8th August 2009 01:13 PM
DAC problem... cracking on speaker... HaLo6 Digital Line Level 5 17th May 2009 02:48 AM
Cracking/Static in Pre-Amp TheVille Solid State 2 17th April 2009 07:42 PM
Cracking noise at clipping ionutgaga Class D 24 27th July 2008 10:38 PM
cracking noise in reference Tony.ca Multi-Way 12 18th October 2006 07:20 PM


New To Site? Need Help?

All times are GMT. The time now is 12:14 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2