Marantz 2275 - trouble in mono - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd April 2004, 05:52 PM   #1
diyAudio Member
 
Join Date: Apr 2004
Location: Santiago, Chile
Default Marantz 2275 - trouble in mono

I have a wood-encased Marantz 2275. Both it and its manual look as if they just came off the assembly line. The receiver works that way, too. Except that, in the phono mode, when I play a record and push in both "mono in" buttons, the channels seem to cancel each other out, with practically no sound -and even that distorted at best. With these buttons out, or only one pushed in, the sound is fantastic. This doesn't happen on any of the other inputs.

Where should I begin in looking for why this is happening?
  Reply With Quote
Old 23rd April 2004, 06:33 PM   #2
diyAudio Member
 
Frank Berry's Avatar
 
Join Date: Sep 2003
Location: Midland, Michigan
The Left and Right channels of your phono cartridge are wired out-of-phase.
__________________
Frank
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Restore a Marantz 2275 for me freax Solid State 26 4th November 2012 01:54 AM
Marantz PMD 101 counter noise and rewind trouble skaboosh Parts 0 29th May 2008 02:10 PM
PSU capacitor replacement for Marantz MA-500 mono amps SimontY Solid State 6 6th May 2008 08:19 PM
Marantz cd 94 MKII dual or mono opams inside elviukai Digital Source 4 14th April 2006 09:22 AM
Marantz CD80 trouble Werner Rem Digital Source 3 27th September 2004 08:53 AM


New To Site? Need Help?

All times are GMT. The time now is 01:16 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2