Help needed with Preamplifier ML 38S - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th April 2004, 08:33 AM   #1
diyAudio Moderator Emeritus
 
lumanauw's Avatar
 
Join Date: Oct 2002
Location: Bandung
Send a message via Yahoo to lumanauw
Default Help needed with Preamplifier ML 38S

I've got problem with Mark Levinson Preamplifier 38S. The volume control is dead at volume 19. Nothing happens if I turn the volume knob up or down. Also cannot adjust balance (which is also with this volume knob).
The sound is badly distorted, at low volume (cannot raise to bigger volume)
I've checked the voltages, the +5, +/-15V are all there. All fuses are OK. It seems like many digital cct inside.

Someone have full schematic to this preamp? Or help repairing it?
  Reply With Quote
Old 19th April 2004, 01:31 AM   #2
diyAudio Moderator Emeritus
 
lumanauw's Avatar
 
Join Date: Oct 2002
Location: Bandung
Send a message via Yahoo to lumanauw
Anyone have the schematic?
  Reply With Quote
Old 19th April 2004, 02:26 AM   #3
diyAudio Member
 
Algar_emi's Avatar
 
Join Date: Oct 2002
Location: Canada, Qc
I may be able to help you. Send me a email. Bye...
  Reply With Quote
Old 19th April 2004, 02:40 AM   #4
fcel is offline fcel  United States
diyAudio Member
 
Join Date: Sep 2001
Location: LA County
One possibility is that the main system controller chip is bad. Call ML, they might send you one to try out.
  Reply With Quote
Old 19th April 2004, 02:59 AM   #5
diyAudio Member
 
Peter Daniel's Avatar
 
Join Date: Jul 2002
Location: Toronto, Canada
Send a message via AIM to Peter Daniel
Algar is an expert on ML preamp. Contact him first.

I wouldn't count on ML support, the company is known for very slow response and ignoring individual inquiries.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help needed ! Inter M R300 schematics needed ! alexclaire Solid State 30 9th September 2009 06:14 AM
LT1964-adj Help Needed or Part Needed lgreen Parts 2 29th June 2007 02:50 PM
Mic PreAmplifier Ayne Solid State 4 13th April 2007 03:18 AM
preamplifier janey Tubes / Valves 4 28th November 2001 11:31 PM


New To Site? Need Help?

All times are GMT. The time now is 07:51 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2