Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

Marantz pm-7200 ground loop / buzzing sound
Marantz pm-7200 ground loop / buzzing sound
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th September 2017, 04:52 PM   #1
dj_holmes is offline dj_holmes  United Kingdom
diyAudio Member
 
Join Date: Nov 2004
Location: london
Default Marantz pm-7200 ground loop / buzzing sound

Hello,

was wondering if anyone could help. Trying to fix this amp for a friend and its producing humming / buzzing sound regardless of volume. It has jumper cables at back and I know for a fact the preamp is working fine so its the power amp not working. I have also tried replacing a few caps in the protection circuitary that may casue this but still getting a loud buzzing sound from it. I also tried measuring dc offset and there was none. I'm stuck! Any suggestions please?
Attached Images
File Type: jpg 20170912_175030.jpg (514.6 KB, 41 views)
File Type: jpg 20170912_175037.jpg (506.5 KB, 38 views)
File Type: jpg 20170912_175047.jpg (524.7 KB, 36 views)
  Reply With Quote
Old 13th September 2017, 05:20 AM   #2
CaseSensitive is offline CaseSensitive  Australia
diyAudio Member
 
Join Date: Aug 2014
Location: Melbourne
humming when nothing else is connected?
  Reply With Quote
Old 13th September 2017, 02:05 PM   #3
dj_holmes is offline dj_holmes  United Kingdom
diyAudio Member
 
Join Date: Nov 2004
Location: london
Quote:
Originally Posted by CaseSensitive View Post
humming when nothing else is connected?
Yes, turns out the large caps has a solder joint that was blown off!! Soldered it resolved problem
  Reply With Quote

Reply


Marantz pm-7200 ground loop / buzzing soundHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ground isolation loop problem ? Motorboat ticking sound rajkumar88 Chip Amps 13 26th April 2017 08:46 PM
hum,ground loop,earth loop problem with your answers please frank2395 Pass Labs 2 17th May 2005 06:46 PM
Digital Woes (Elite DV-45A ground loop and bad sound) pjpoes Digital Source 0 7th March 2005 07:32 PM
Buzzing, could it be a ground loop? JoeBob Tubes / Valves 3 14th July 2003 02:24 AM
does connecting mains ground with circuit ground create a ground loop? jarthel Everything Else 0 25th June 2003 12:55 PM


New To Site? Need Help?

All times are GMT. The time now is 08:51 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki