Krell KSA 50 pcb - Page 838 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th November 2012, 08:10 AM   #8371
HellMan is offline HellMan  Finland
diyAudio Member
 
HellMan's Avatar
 
Join Date: Apr 2008
loek: Got the boards yesterday, thank you!

When I picked them up at my local post office and ripped the package straight open I first thought you've accidentally sent 2 pairs of boards, but as it turns out these are nearly twice as thick as my previous 5 boards :-O
Bulletproof!!! <3
__________________
He||Man
  Reply With Quote
Old 10th November 2012, 03:01 PM   #8372
loek is offline loek  Netherlands
diyAudio Member
 
Join Date: Feb 2005
Location: The Hague
Indeed first Quality Hellman. So from now on we can follow your KSA50 amp story here??
Good luck with the project anyway.
Loek
  Reply With Quote
Old 10th November 2012, 03:50 PM   #8373
HellMan is offline HellMan  Finland
diyAudio Member
 
HellMan's Avatar
 
Join Date: Apr 2008
Sure, as soon as I get the parts for power sources, cooling and output transistors which entirely depends on how much overtime my boss makes me do. We have a sort of deal that for the exchange of my precious overtime boss buys me the parts and/or equipment I need.
__________________
He||Man
  Reply With Quote
Old 13th November 2012, 06:01 AM   #8374
rss388 is offline rss388  United States
diyAudio Member
 
Join Date: Dec 2007
Hi Folks,

Looks like I am late to the party...

Does anyone have another pair of boards they would sell me? Particularly if you are in the US to make transit simple...

Does anyone have done any comparisons between the KSA50 and the KSA80, which I happen to have?

Cheers!
  Reply With Quote
Old 6th January 2013, 04:47 PM   #8375
alibear is offline alibear  United Kingdom
diyAudio Member
 
Join Date: Feb 2009
Location: Somerset
Hi all, what VA rating transformer would I need to supply the front end up to but not including the drivers of the KSA50 clone. Also what VA if I included the drivers
Thanks for your help
Alan
  Reply With Quote
Old 14th January 2013, 12:23 PM   #8376
henryve is offline henryve  South Africa
diyAudio Member
 
henryve's Avatar
 
Join Date: Jun 2008
Location: Strand
Well, almost there.

I started up my PinkMouse Main and Driver boards yesterday evening and today, all voltages looking good to go for connection to my output stages. First I have some more metalworking to do on the main heatsinks.
  Reply With Quote
Old 18th January 2013, 03:56 PM   #8377
THD+N is offline THD+N  United States
diyAudio Member
 
Join Date: Jul 2007
Location: Orlando, Florida
Hello Everyone! I have looked through almost 800 plus pages of this thread. I normally build tube based amps, but have gotten a bug to build something solid state recently.

Does anybody have any more boards available? If not, I'll have to design my own and there will be another version out there!
  Reply With Quote
Old 23rd January 2013, 03:38 AM   #8378
Arick is offline Arick  Canada
diyAudio Member
 
Arick's Avatar
 
Join Date: Dec 2008
Location: Montréal
Quote:
Originally Posted by THD+N View Post
Hello Everyone! I have looked through almost 800 plus pages of this thread. I normally build tube based amps, but have gotten a bug to build something solid state recently.

Does anybody have any more boards available? If not, I'll have to design my own and there will be another version out there!
Hi,
This gentlemen on e-bay has a pcb suitable to make a very nice clone.

High Power Pure Class A Amplifier PCB KSA100 | eBay

I did purchase a set and I must say it is very well made. It would be probably easier than making your own. If you want more pictures or info just PM me
Cheers,
Eric
  Reply With Quote
Old 23rd January 2013, 08:13 AM   #8379
diyAudio Moderator
 
pinkmouse's Avatar
 
Join Date: Apr 2002
Location: Chatham, England
Quote:
Originally Posted by alibear View Post
Hi all, what VA rating transformer would I need to supply the front end up to but not including the drivers of the KSA50 clone. Also what VA if I included the drivers
Thanks for your help
Alan

I would just do the front end, leave the drivers on the main supply. 50VA should do you.
__________________
Rick: Oh Cliff / Sometimes it must be difficult not to feel as if / You really are a cliff / when fascists keep trying to push you over it! / Are they the lemmings / Or are you, Cliff? / Or are you Cliff?
  Reply With Quote
Old 23rd January 2013, 08:16 AM   #8380
diyAudio Moderator
 
pinkmouse's Avatar
 
Join Date: Apr 2002
Location: Chatham, England
Quote:
Originally Posted by THD+N View Post
If not, I'll have to design my own and there will be another version out there!
If you look through the thread, you'll find all my Eagle PCB files. Use them as-is, or modify away.
__________________
Rick: Oh Cliff / Sometimes it must be difficult not to feel as if / You really are a cliff / when fascists keep trying to push you over it! / Are they the lemmings / Or are you, Cliff? / Or are you Cliff?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



New To Site? Need Help?

All times are GMT. The time now is 03:25 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2