Krell KSA 50 pcb - Page 782 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd December 2008, 08:26 PM   #7811
neychi is offline neychi  Croatia
diyAudio Member
 
Join Date: Feb 2005
Location: zagreb
@Nico, yes I measured voltage on emitter resistor, between transistor emitter and speaker output (+)

@Andrew, 0.3V cca
  Reply With Quote
Old 23rd December 2008, 08:32 PM   #7812
diyAudio Member
 
Nico Ras's Avatar
 
Join Date: Nov 2005
Location: East Coast of South Africa
Quote:
Originally posted by neychi
@Nico, yes I measured voltage on emitter resistor, between transistor emitter and speaker output (+)

@Andrew, 0.3V cca
You say that it plays music okay but you cannot adjust bias. What voltage are you measuring over the emitter resistor. I am thinking maybe that the Vbe multiplier is open circuit.

If this is the case then the amplifier will still operate but in class B or maybe a very small quiescent current, but you should still see a very small voltage change if you turn the pot.
  Reply With Quote
Old 23rd December 2008, 08:35 PM   #7813
diyAudio Member
 
Nico Ras's Avatar
 
Join Date: Nov 2005
Location: East Coast of South Africa
If you suspect the Vbe multiplier also then change it. Use any NPN transistor even a small signal type it will work. It does not have to be on the heat sink for testing purposes. If it works after the change then you know what the problem is.
  Reply With Quote
Old 23rd December 2008, 08:43 PM   #7814
neychi is offline neychi  Croatia
diyAudio Member
 
Join Date: Feb 2005
Location: zagreb
Ok, now I saw that on Wiki:

"Slowly turn the bias pot to increase the output idle current, you can also measure this as the voltage across the 25ohm driver emitter resistors, nothing happens at first, basically until the board output voltage reaches about 1.2v across r127 & 128, then the outputs start to turn on and you will read a voltage across Re1...keep increasing until you have about 0.2 volts across Re1..."

I'll try once again tomorrow.
  Reply With Quote
Old 23rd December 2008, 08:51 PM   #7815
neychi is offline neychi  Croatia
diyAudio Member
 
Join Date: Feb 2005
Location: zagreb
Thanks Nico

Maybe I didn't turn the bias pot enough. But I was thinking that after several turns some difference will appear.
  Reply With Quote
Old 23rd December 2008, 09:11 PM   #7816
diyAudio Member
 
Nico Ras's Avatar
 
Join Date: Nov 2005
Location: East Coast of South Africa
Quote:
Originally posted by neychi
Thanks Nico

Maybe I didn't turn the bias pot enough. But I was thinking that after several turns some difference will appear.
I am happy for you that it is changing. Most multi-turn pots have 25 turns so it needs several turns to make a change, this is good. In the low bias state you can run the KRELL CLONE in class AB, it is quite happy and will operate cool under almost all conditions. For it to run in class AB mode adjust low bias for about 25 mV across Re of output transistors.


Good listening.

Nico
  Reply With Quote
Old 24th December 2008, 09:32 AM   #7817
neychi is offline neychi  Croatia
diyAudio Member
 
Join Date: Feb 2005
Location: zagreb
Hi Guys!

Well, it's WORKING!!! I set the Bias at 1.9A, it is hot, but not too hot, cca 50 C after one hour.

Thanks everybody!

Regards
Attached Images
File Type: jpg dsc00096-2.jpg (42.5 KB, 908 views)
  Reply With Quote
Old 24th December 2008, 09:41 AM   #7818
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
which part is ~50degC?
__________________
regards Andrew T.
  Reply With Quote
Old 24th December 2008, 09:56 AM   #7819
neychi is offline neychi  Croatia
diyAudio Member
 
Join Date: Feb 2005
Location: zagreb
Heat sinks for output transistors and heat sinks for drivers are on the same temperature. Heatsinks for outputs first go hot around the transistors but after few minutes temperature is the same all around.

I can put my fingers on the transistors without problem.
  Reply With Quote
Old 24th December 2008, 10:30 AM   #7820
diyAudio Member
 
Nico Ras's Avatar
 
Join Date: Nov 2005
Location: East Coast of South Africa
Quote:
Originally posted by neychi
Heat sinks for output transistors and heat sinks for drivers are on the same temperature. Heatsinks for outputs first go hot around the transistors but after few minutes temperature is the same all around.

I can put my fingers on the transistors without problem.
WOW! That is a beautifully machined box, resembles the real KRELL stepped front panel and all.

Nico
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



New To Site? Need Help?

All times are GMT. The time now is 05:33 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2