Technics SU-V85A - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State
Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th January 2017, 02:35 PM   #1
diyAudio Member
 
Join Date: Jan 2017
Default Technics SU-V85A

I have a Technics SU-V85A. A friend plugged an mp3 player into the Aux 1 input and the amp popped and went into protection mode. I couldn't get it to recover. I found the schematics and started doing some checking. My probe slipped and I shorted a cap. and a resister. In trying to replace them I tried a 1/4 watt 22 Ohm resister and it fried. I have a problem with the resistor at R477 on the schematic for the Voltage control Amp. circuit. it says it is a 22 Ohm resistor but no clue as to weather it is a 1/4 watt or a 1/2 watt. I have tried 1/4 watt and it fried and popped the cap at C463. Anyone have any idea?
  Reply With Quote
Old 6th January 2017, 03:01 PM   #2
diyAudio Member
 
JonSnell Electronic's Avatar
 
Join Date: Dec 2012
Location: The Jurassic Coast, England. GB
The only thing that could pop C463 is reversed polarity as it will stand 100Volts across it. R477 supplies IC401 which I would think has been damaged.
__________________
Support for Fender, Marshall and all Valve Equipment; Audio Innovations, Audiorama FU29, Quad and Leak. www.jonsnell.co.uk
  Reply With Quote
Old 6th January 2017, 03:07 PM   #3
diyAudio Member
 
Join Date: Jan 2017
That's what I was thinking. I tried reversing R477 And they both fried again. The polarity on c463 is correct. Thanks!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Technics SU V85A yeti Solid State 1 6th January 2017 02:16 PM
Technics SU V85A Depaj Solid State 11 10th March 2016 09:48 AM
Panasonic SU-2700 Repair (Otherwise known as the Technics SU Z1) MChandler Solid State 22 11th April 2013 07:25 AM
Technics SU-A900Mk2 OXAUDIO Chip Amps 14 24th October 2012 01:50 PM


New To Site? Need Help?

All times are GMT. The time now is 04:09 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright 1999-2017 diyAudio

Content Relevant URLs by vBSEO 3.3.2
Wiki