Sugden Masterclass IA-4 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State
Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd January 2016, 11:10 AM   #1
diyAudio Member
 
Join Date: Jan 2016
Default Sugden Masterclass IA-4

Hi Guys,
I have a Sugden Masterclass IA-4. Few years old now.
The left channel outputs noise, heard via speaker as well as seen on the scope. The type of noise kind of changes here and there. Right channel is ok.
Volume attenuation has no effect on noise. I have disconnected the pre-amplifier and just run the left channel amplifier board and the noise still exists.

It appears that the noise is most apparent after the power supply clicks in and the transistors are warming up....?

Im not an expert on Class A amps, and was wondering if someone could point me in the direction of how best to start. Fairly sure the fault lies on the Left channel amplifier board. Possibly caps?

I've sent an email to Sugden - Patrick, but have not received anything further and thought I'd try here.

Many thanks,
jas
  Reply With Quote
Old 22nd January 2016, 10:50 PM   #2
diyAudio Member
 
Join Date: Jan 2016
Here are the waveforms viewed.
Attached Images
File Type: jpg IMG_2055.jpg (522.3 KB, 60 views)
File Type: jpg IMG_2056.jpg (534.7 KB, 56 views)
  Reply With Quote
Old 22nd January 2016, 11:55 PM   #3
diyAudio Member
 
Join Date: Apr 2010
Location: Coffs Harbour
A 5MHz output would be oscillation - instability due to a component or soldering failure. The problem for anyone wanting to assist (few repairers would experienced at these newer Sugden products), is finding a schematic to base any suggestions on.
__________________
Ian
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Magnum IA 170 .... east electronics Solid State 9 11th June 2015 11:21 PM
NAKAMICHI IA-2 AMP HELP ftpols Solid State 5 13th January 2015 01:32 PM
Sugden Masterclass IA-4 schematic needed Dobs Solid State 8 29th February 2012 09:06 AM
WTB: NuForce IA-7 V2 cartman Swap Meet 0 17th September 2007 08:09 PM


New To Site? Need Help?

All times are GMT. The time now is 03:51 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Copyright 1999-2016 diyAudio

Content Relevant URLs by vBSEO 3.3.2
Wiki