diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Solid State (http://www.diyaudio.com/forums/solid-state/)
-   -   Help! Problem in My Receiver - Marantz RS685 (http://www.diyaudio.com/forums/solid-state/28033-help-problem-my-receiver-marantz-rs685.html)

RaymondQ 11th February 2004 06:18 PM

Help! Problem in My Receiver - Marantz RS685
 
Hi All,

Recently I found that my receiver seems to be "sick". The audio of both channels is shut off for couple seconds then back on again. I can hear the clicking sound of the rally (?) when the audio is on and off. This usually happened when I first turned the receiver on (still cold?). After a while (~10 times of the problem), everything seems to be OK :confused: .

There is no shortage of the speaker cables/IC, or even the speakers themselves.

Does anyone know what is going on and know a way to fix it? As I remembered, I once had it fixed by some technician with the similar problem (the receiver shutting itself off), but I forgot to ask him where the problem is or which part went wrong :( .

Thanks for any help or advise.

Raymond

EchoWars 13th February 2004 10:22 AM

Either the protection circuit has a problem (perhaps the transistor that drives the relay), or your DC offset at the output is too high.

Easiest to check offset and see. Adjust to '0' and perhaps the problem will disappear. If not, the protection has problems (old leaky caps or weak transistors).


All times are GMT. The time now is 07:09 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2