diyAudio (
-   Solid State (
-   -   Peavey M-2600 trouble (

Cobra2 10th February 2004 01:55 AM

Peavey M-2600 trouble
Some friend dragged this defect amp to my house, and asked if anything can be done...

Problem 1: DC on output (= ca. 45V)
Problem 2: 2 x 2W(?) resistors on the PSU-board is burned beyond recognition....

Any tips / schematics?

Arne K

Netlist 10th February 2004 06:39 AM

Your 2 R's are 550ohm/5W and supply the +/-15V for the opamps.
Mail me if necessary.

/Hugo :)

AJT 10th February 2004 07:09 AM

hi netlist,
can i have a copy of schematics please?
thanks a lot!

Netlist 10th February 2004 07:13 AM

I'll put my scanner at work this afternoon.
We'll see what comes out ;)


AJT 10th February 2004 11:18 PM

hi netlist,
your mails came in garbled, as i only have 4mb storage, can you resend 1/3 and 2/3 to then 3/3 to thanks and sorry for the trouble,

best regards,

Cobra2 10th February 2004 11:28 PM

I had the same problem..."bin" file? ...but I got some of it, enough..I hope.

Arne K

Genomaster 19th October 2009 08:13 AM

Could you send that Peavey M-2600 schematic also to me?
I just bought one, and it was already disassembled. Now i have bit problems to fix that.
Here is my mail genomaster (at)

Netlist 19th October 2009 09:01 AM

Genomaster, mail sent.
Tony and Arne, I just realized, after almost six years, that my mail didn't reach you well.
Let me know if you still want the schematic.


diyrandy50 1st April 2011 02:39 AM

Could I get a schematic also. Thanks

diyrandy50 1st April 2011 02:45 AM

I need the schematic for the Peavey M 2600 if it is still available.
I'm new to site so please excuse any flubs.

All times are GMT. The time now is 02:51 AM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2