question about mosfet direction - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 31st July 2015, 07:42 PM   #1
diyAudio Member
 
Join Date: Feb 2015
Default question about mosfet direction

building this hybrid amp...

and the arrow on the P and N channel mosfet is opposite from the schematics (gate to source and source to gate)

my first amp here trying to make sense...

thanks

Martin Gagnon

HybridPA.jpg
  Reply With Quote
Old 31st July 2015, 07:48 PM   #2
Did it Himself
diyAudio Member
 
richie00boy's Avatar
 
Join Date: Nov 2003
Location: Gloucestershire, England, UK
Yes, the arrows are the wrong way round, a drawing mistake. I have seen this kind of mistake a few times.
__________________
www.readresearch.co.uk my website for UK diy audio people - designs, PCBs, modules and more.
  Reply With Quote
Old 31st July 2015, 08:08 PM   #3
diyAudio Member
 
Join Date: Feb 2015
thank you

i'm tripple checking before soldering

Martin Gagnon
  Reply With Quote
Old 1st August 2015, 09:45 AM   #4
diyAudio Member
 
Join Date: Jun 2011
Location: Sydney
May I ask where you got the board from? I'm interested in such a design.
  Reply With Quote
Old 1st August 2015, 10:41 AM   #5
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
the b/w diagrams on the right are correct.
The FET labels are correct.

It's only the direction of the blue arrow that is wrong.
__________________
regards Andrew T.
Sent from my desktop computer using a keyboard
  Reply With Quote
Old 1st August 2015, 02:43 PM   #6
diyAudio Member
 
Join Date: Feb 2015
Quote:
Originally Posted by triplej View Post
May I ask where you got the board from? I'm interested in such a design.
20W-Class-tube-input-MOSFET-SE-output-Borbely-architecture
  Reply With Quote
Old 1st August 2015, 04:47 PM   #7
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
And I'd guess that their customer support is as bad as their schematic.
Try asking them your question. See if you get any answer !
__________________
regards Andrew T.
Sent from my desktop computer using a keyboard
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mosfet question. nigelwright7557 Solid State 4 15th February 2014 01:51 PM
Mosfet question mike49504 Car Audio 7 17th March 2010 03:09 AM
mosfet question mike49504 Car Audio 5 9th December 2009 07:13 AM
Fairchild Stealth 4A/600V direction question milen007 Parts 0 27th May 2008 03:34 AM
Mosfet Regulator Question Rory Christ Pass Labs 0 28th March 2004 02:35 AM


New To Site? Need Help?

All times are GMT. The time now is 05:29 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2