SC480 Troubles.... - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th February 2004, 10:01 AM   #1
Tensop is offline Tensop  Lebanon
diyAudio Member
 
Join Date: Jul 2003
Location: Chapel St.
Default SC480 Troubles....

hi guys, most of us in australia know what an sc480 amp module is so i guess this is directed at you. I'm getting +22v DC offset on the speaker outputs and the negative rail isnt discharging at all when power is switched off, does anyone have any ideas as to the cause of this problem?
  Reply With Quote
Old 7th February 2004, 11:44 AM   #2
b<ben>n is offline b<ben>n  Australia
diyAudio Member
 
Join Date: Dec 2003
Location: in my house
why dont u e-mail silicon chip
  Reply With Quote
Old 7th February 2004, 12:57 PM   #3
sss is offline sss  Israel
diyAudio Member
 
sss's Avatar
 
Join Date: Jul 2003
Location: Israel , haifa
Send a message via ICQ to sss
Default Re: SC480 Troubles....

Quote:
Originally posted by Tensop
I'm getting +22v DC offset on the speaker outputs
check the output transistors ,if ok check if the feedback is not disconnected
  Reply With Quote
Old 7th February 2004, 10:51 PM   #4
Tensop is offline Tensop  Lebanon
diyAudio Member
 
Join Date: Jul 2003
Location: Chapel St.
Ok, got it working. was a faulty transistor on the negative feedback, replaced and fixed.

thanks sss
  Reply With Quote
Old 8th February 2004, 11:44 AM   #5
palesha is offline palesha  India
diyAudio Member
 
Join Date: Nov 2001
Location: Pune India
Congrates! we hv heard a lot about SC480. How about giving schematics of the circuit? We will be happy to study it.
MP
  Reply With Quote
Old 8th February 2004, 12:00 PM   #6
Warp Engineer
On Holiday
 
AudioFreak's Avatar
 
Join Date: Oct 2001
Location: Queensland, Australia
I'm not sure, but I suspect that the schematic for the SC480 amplifier as published by Silicon Chip is protected by a current copyright. That being the case, you should not post it here.
__________________
- Dan
  Reply With Quote
Old 8th February 2004, 12:33 PM   #7
diyAudio Member
 
Workhorse's Avatar
 
Join Date: Dec 2004
Arrow Commentable Thoughts

Quote:
Originally posted by AudioFreak
I'm not sure, but I suspect that the schematic for the SC480 amplifier as published by Silicon Chip is protected by a current copyright. That being the case, you should not post it here.

Thats True They have copyrights and u shouldnot post it here.

Regards
Ampman
  Reply With Quote
Old 8th February 2004, 07:04 PM   #8
Tensop is offline Tensop  Lebanon
diyAudio Member
 
Join Date: Jul 2003
Location: Chapel St.
Quote:
Originally posted by AudioFreak
I'm not sure, but I suspect that the schematic for the SC480 amplifier as published by Silicon Chip is protected by a current copyright. That being the case, you should not post it here.

thats true, and is the reason why i did not post a schematic. however there are amps that are... extremely close in design, that are F.T.P
  Reply With Quote
Old 1st March 2004, 06:39 AM   #9
palesha is offline palesha  India
diyAudio Member
 
Join Date: Nov 2001
Location: Pune India
Atleast tell us the issue of Silicon chip so that we can call it.
MP
  Reply With Quote
Old 1st March 2004, 08:12 AM   #10
b<ben>n is offline b<ben>n  Australia
diyAudio Member
 
Join Date: Dec 2003
Location: in my house
jan 03
and feb 03
of silicon chip
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SC480 Amplifier Kit Problem Stefan1 Solid State 22 15th September 2013 05:19 AM
jaycar sc480 t03 ver 2 johndoe Solid State 1 17th November 2008 05:58 AM
SC480's trouble rotorhed Solid State 0 9th September 2007 06:07 PM
Modifying the SC480 for 2 ohm load guitar_joe Solid State 6 10th August 2007 07:09 PM
My new SC480 Pair Dilby© Solid State 3 5th March 2007 02:17 AM


New To Site? Need Help?

All times are GMT. The time now is 08:24 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2