Left channel sometimes starts later on Marantz PM-54 II - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th July 2015, 05:17 PM   #1
diyAudio Member
 
Join Date: May 2012
Default Left channel sometimes starts later on Marantz PM-54 II

Dear All,

Thanks to forum members my daughter has been enjoying a nice phono (L75) and Marantz PM-54 II.

Lately we notice that the left channel does not work right away. One has to up the volume and eventually it starts !

Any suggestions, sounds like a capacitor that is dry or leaking but I am not proficient just gut feeling.

Thank you
  Reply With Quote
Old 18th July 2015, 05:22 PM   #2
diyAudio Member
 
Join Date: Nov 2004
Location: Germany
Sounds like the protection relay needs to be cleaned / replaced (about the same amount of work either way). A total classic as far as age-related ailments go, a search should turn up loads of info.
  Reply With Quote
Old 19th July 2015, 03:52 AM   #3
diyAudio Member
 
Welcome's Avatar
 
Join Date: Mar 2013
Indeed, definitely the relay. Dpst, usually quite normal type which is easy and cheap to find.
__________________
  Reply With Quote
Old 19th July 2015, 03:31 PM   #4
diyAudio Member
 
Join Date: May 2012
Default finding the component :(

Thank you for confirmation about the Relay. I really am not very familiar with using schematics. I did find page 16 speaker relay but not sur that is the culprit and it it for 64II.

Would some member be kind enough to point out the components envolved and a hint of the procedures. I am fairly good at soldering (self taught and have the tools) but not equiped with oscilloscope or so, just the basic digital meter.

Here is a link to the manual: http://www.vintageshifi.com/repertoi...ice-Manual.pdf


Many thanks!
  Reply With Quote
Old 20th July 2015, 06:48 AM   #5
diyAudio Member
 
Welcome's Avatar
 
Join Date: Mar 2013
Looks like it has separate relays for the A and B speaker terminals. Connect your speakers to B instead, and you have a brand new relay which shouldn't have the problem you're experiencing.
__________________
  Reply With Quote
Old 20th July 2015, 09:13 AM   #6
diyAudio Member
 
Join Date: May 2012
Thank you for this brilliant suggestion.

Just changed it. For now impossible to confirm it worked as the issue is intermittent but will give feedback in a few weeks.

This forum is amazing.

Thanks !
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade Marantz PM-54 II phono stage lecentaur Solid State 10 20th June 2015 03:31 AM
70s Marantz PM 550 DC with silent left channel Participant Solid State 6 4th November 2013 08:33 AM
marantz pm 7200 left channel distortion chris212 Solid State 11 28th March 2013 04:15 PM
Marantz PM-66SE Right Channel Fault Taps Solid State 1 8th February 2010 12:23 PM
Marantz PM-66SE Blown Channel Chudley Solid State 2 8th May 2007 07:28 PM


New To Site? Need Help?

All times are GMT. The time now is 06:49 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2