Technics SU-V3 negative voltage at output!!! - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd July 2015, 05:01 PM   #1
reji is offline reji  India
diyAudio Member
 
Join Date: Apr 2006
Location: dubai
Default Technics SU-V3 negative voltage at output!!!

I got this amp from a friend which is already tried to repair by someone else and still have problem with one channel. Negative voltage is showing at the output stage in one channel and other channel is quite normal. I checked the output transistors and driver transistors, all shows good. When I removed the Q319(c2631) there is no negative voltage at the output. 2SC2631, 2SA1123,2SA992 and 2SK109 is not available here in local market. Only 2SA1015 and 2SC1845 is available here. Anyone know substitute for 2SC2631,2SA1123 and 2SA992? Please help !!!
Attached Images
File Type: jpg image.jpg (216.4 KB, 33 views)
  Reply With Quote
Old 3rd July 2015, 05:37 AM   #2
reji is offline reji  India
diyAudio Member
 
Join Date: Apr 2006
Location: dubai
Any substitute in MPSA** or 2N**** for 2SC2631,2SA1123 ???
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Technics SU-V4 idle current and clamp voltage adjustment confusion Welcome Solid State 2 16th November 2013 01:16 PM
Panasonic SU-2700 Repair (Otherwise known as the Technics SU Z1) MChandler Solid State 22 11th April 2013 07:25 AM
Is STK2038B the output stage for Technics SU-Z55? AX816 Chip Amps 5 14th March 2011 05:08 PM
Technics SU-8077 nev1956 Parts 2 20th November 2007 03:56 PM


New To Site? Need Help?

All times are GMT. The time now is 12:16 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2