Threshold T400 repair, need help - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 19th April 2015, 05:36 PM   #1
diyAudio Member
Join Date: Apr 2015
Location: Austria
Default Threshold T400 repair, need help

Hello to all audio enthusiasts!

I have an twentyone years old Threshold T400 amplifier (European version) bought pre-owned at 1998 in Germany. Since then I use only this amplifier and I love its smooth and amazing sound. But now it has a problem and I need your help!

From the beginning:

About three weeks ago I detected a ugly cracking added to the sound at the mids on the right speaker. First I thougt, the mid chassis of the speaker is defect, but after some left/right changes it exposes, the cause must be the amplifier. Then I tried a CD with only single bass frequencies from 20 Hz upward to 150 Hz and it reproduces at every fequency the same cracking at the mids of the right speaker with recognizable beat tones at 50 Hz, 100 Hz and 150 Hz (You know, in Europe we have 50 Hz power frequency). Some search at the internet suggested a problem with the capacitors of the power supply.

A good friend with electronic skills helped me carefully disassembling the amplifier.

We found a defect capacitor at the right channel. The capacitor must be broken internally, because it has no capacitance. This capacitor have bended up his crimping a little bit on the top. The other three capacitors are working but the capacitor at the same position at left channel have a crack at the top plate. The two rectifiers are optically and measured okay. The other parts, especially the other capacitors on the top printed circuit board and also all the soldering pads seems to be optically in very good condition. Nothing looks like twentyone years old, also the two input section boards at the sides. I did not open the amplifier parts at the sides, so I do nothing know and seen about that parts behind the heatsinks. I don't like to disassemble more as necessary.

We are not electronics technicians or audio electronics experts. We are only audio interested enthusiasts.

Actual status:

I hope, that only the capacitor is defect. So I will change now this four capacitors with new ones and then after a little bit measuring and reassembling I will give it a try.

The four fitted old capacitors are:

Cornell Dubilier
31.000 F 75 VDC
Made in USA

Capacity: 31.000 F
Voltage: 75 Vdc
Tolerance: -10 % to +75 %
Temperatur range: -40 C to +85 C
Life time: 1000 h or maybe 2000 h at +85 C (there are both contradictory informations in the specs)
Diameter: 2 in (50.8 mm)
Length: 5.125 in (130.18 mm)
Terminal Style: High Post
Post Diameter: 0.314 in (8 mm)
Post Height max.: 0.281 in (7.1mm)
Terminal spacing: 0.88 in (22.23 mm)
Thread: 10-32
Insulation: PVC (black color)
Can Style: Standard
ESR max. at 25 C and 120 Hz: ? mOhm (value unknown, as I only have the specs for the 27.000 F and 41.000 F types)
Ripple max. at 85 c and 120 Hz: ? A (value unknown, as I only have the specs for the 27.000 F and 41.000 F types)

About the next steps:

The fitted old capacitor types are no more available. I assume, these were state of the art in the 90s, and there should be more advanced parts available today.

For the replacement, I don't want to make any mechanical modifications, so only capacitors with the same diameter, terminal style, terminal spacing, insulation and can style are acceptable for me. They might have nevertheless a larger capacitance, voltage, temperature maximum and life time. The next larger length is acceptable, as there is some space available.

I want to avoid shipping my T400 around the world. Instead I hope to learn something.

The nice offer from Threshold Audio about an upgrade to the actual STASIS technology is known to me, but I like my T400 and its sound as it is (was). So I hope to get it repaired by myself with your help.

Here are now my questions:

Is more capacitance respectively lesser ESR for this part possible? Is there a maximum/minimum limit for the T400 amplifier?

Is there additionally anything important for the replacement?
Has someone ideas or suggestions for an optimal replacement?
Is there anything I should additionally check?
Does anyone know other parts which should be replaced as a precautionary measure during this repair?
Has someone additional suggestions or tips for me?

  Reply With Quote


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Threshold 4000 repair. Need some help. tonebells Pass Labs 74 18th July 2015 11:21 PM
Rockford T400.4 repair help indpntanarchy23 Car Audio 17 14th October 2013 02:33 AM
Threshold 400a repair ******78 Pass Labs 26 8th May 2012 11:19 PM
Threshold T800 and T400 high123bid Solid State 0 10th March 2011 02:09 PM
Threshold T2 T3 T400 Service manuals emilg1955 Vendor's Bazaar 0 27th June 2007 12:35 AM

New To Site? Need Help?

All times are GMT. The time now is 10:40 AM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2