Krell KSA 300s Integrated circuit - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old Yesterday, 01:51 AM   #1
xmates is offline xmates  Viet Nam
diyAudio Member
 
Join Date: Jul 2011
Default Krell KSA 300s Integrated circuit

Hi everyone,
I'm from Vietnam. My Krell KSA 300s is now running with very low level at one channel. So I get a Technician and he found that the Integrated circuit( I don't know whether this named in English is correct) at Q33 position on driver board is dead. It is marked with D9517- 2N5564
I checked with Krell and they give me the unbelievable price: $65 for each.
Does some one have this? Or where I can buy the exact one to replace because my techician said this one is not a normal as the other ( he checked and found st strange- this is a double, one long one short,or st like that, my god , I don't know what it means).
I find the 2n5564 on alibaba but they don't have the mark D9517, just 2N5564. This pos is the start of signal so I think the bad one can cause terrible at the ending output.
Tks n Brgds!

Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.
  Reply With Quote
Old Yesterday, 02:21 AM   #2
diyAudio Member
 
Join Date: Jun 2001
Location: USA, Grand Prairie, Tx
Linear Systems says their LSK389C is a replacement, see here. This also means that a well matched pair of high IDSS 2SK170 BL's or 2SK170V will work as well.

Because the 170's are still somewhat available at a reasonable price you might want to consider replacing the 2N5564 in the other channel as well.
__________________
KC
  Reply With Quote
Old Yesterday, 02:47 AM   #3
xmates is offline xmates  Viet Nam
diyAudio Member
 
Join Date: Jul 2011
Tks Mr Chamberman, But If I replace this, any problem with sounding? Should I take a pair and remove the one on other chanel for the same sounding at both?
Help plS!
  Reply With Quote
Old Yesterday, 03:00 AM   #4
diyAudio Member
 
Join Date: Jun 2001
Location: USA, Grand Prairie, Tx
Sorry wrong link in the previous post. Here is the cross ref sheet.
__________________
KC
  Reply With Quote
Old Yesterday, 04:53 AM   #5
xmates is offline xmates  Viet Nam
diyAudio Member
 
Join Date: Jul 2011
D9517- 2N5564, what does D9517 meaning? Can I do without this mark? Sorry I don't have any electronic knowledge, the technician is also not sure about D9517.
Mny tks!
  Reply With Quote
Old Yesterday, 11:04 AM   #6
diyAudio Member
 
Join Date: Jun 2001
Location: USA, Grand Prairie, Tx
Quote:
Originally Posted by xmates View Post
D9517- 2N5564, what does D9517 meaning? Can I do without this mark? Sorry I don't have any electronic knowledge, the technician is also not sure about D9517.
Mny tks!
D9517 = Manufacturer Date/Batch coding. Probably 17th week of 1995 if I had to guess.
__________________
KC
  Reply With Quote
Old Yesterday, 11:18 AM   #7
diyAudio Member
 
Join Date: Jun 2001
Location: USA, Grand Prairie, Tx
Quote:
Originally Posted by xmates View Post
Tks Mr Chamberman, But If I replace this, any problem with sounding? Should I take a pair and remove the one on other chanel for the same sounding at both?
Help plS!
Yes I would definitely change the input Jfet pair in the functioning channel as well. Not only to maintain symmetry between the channels and eliminate any chance of sound differences between them due to the new Jfet's, but also for reliability. If the 2N5564 has failed in one channel then it may very well be on its last leg in the second channel.

DIYAUDIO user Alweit sells matched quads of genuine Toshiba 2SK170BL's on Ebay under the same user name. Alweit's Jfet's are well matched and not expensive. Beware, there are a lot of fake Jfet's out there. If you purchase them from China off of Ebay you WILL RECEIVE FAKES. I would contact Alweit and ask him if he has a matched quad with an Idss of > 10ma that you can purchase.
__________________
KC
  Reply With Quote
Old Yesterday, 12:20 PM   #8
Ketje is offline Ketje  Belgium
diyAudio Member
 
Join Date: Dec 2012
Location: Flanders
You could also consider using Toshiba's 2SK389.
Different envelope, somewhat more difficult to replace .
Mona
  Reply With Quote
Old Yesterday, 12:35 PM   #9
diyAudio Member
 
Join Date: Jun 2001
Location: USA, Grand Prairie, Tx
Quote:
Originally Posted by Ketje View Post
You could also consider using Toshiba's 2SK389.
Different envelope, somewhat more difficult to replace .
Mona
I wouldn't do that. The 2SK389 only has a total Pd rating of 400mw, the 2n5564 is rated for 650mw. If the reason for the failure was due to running a rather high Pd then the 2sk389 will fail quickly. The 2sk170 pair will have a total Pd of 800mw and be a more reliable choice.
__________________
KC
  Reply With Quote
Old Yesterday, 02:22 PM   #10
Ketje is offline Ketje  Belgium
diyAudio Member
 
Join Date: Dec 2012
Location: Flanders
Quote:
Originally Posted by Chamberman View Post
I wouldn't do that. The 2SK389 only has a total Pd rating of 400mw, the 2n5564 is rated for 650mw. If the reason for the failure was due to running a rather high Pd then the 2sk389 will fail quickly. The 2sk170 pair will have a total Pd of 800mw and be a more reliable choice.
The photo shows a TO-18 envelope so 650mW
It's a differential input stage, Pd is not an issue here.There is no provision made to adjust a possible inbalance, two 170's is not a good idea unless you modify the circuit an glue them together.
Mona
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Krell KSA-300S will not turn on fcel Solid State 54 26th March 2015 03:01 PM
krell ksa 5 Zen Mod Solid State 72 27th October 2013 10:35 PM
krell ksa 300s right channel dead maybe transistor problem?? yipyip55 Solid State 25 19th July 2012 07:21 PM
Krell KSA-300S cliks off rextech Solid State 0 15th July 2011 11:31 AM
Krell KSA-300S Chassis Restoration john65b Solid State 5 7th June 2010 03:00 PM


New To Site? Need Help?

All times are GMT. The time now is 06:10 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2