Today's Puzzler ?? - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th January 2004, 12:26 AM   #1
sam9 is offline sam9  United States
diyAudio Member
 
sam9's Avatar
 
Join Date: Jun 2002
Location: Left Coast
Default Today's Puzzler ??

Subject is a CFB amp, two pairs of output devices. I've built CFB amps before and subdued the oscillations and made them work. This one does something new. I've always been careful to be sure the heatsink is grounded: A- for saftey and B- to avoid it being an antenna.

On this amp, if I leave the heatsinks floating I see no oscillation on my scope. If I connect them to ground I see signs of oscillation on the scope and the output transistors start heating up even with no input or load. I noticed that when I touch a heatsink the oscillations go away (I'm on a insulated pad and have one hand in my pocket - I'm nut that nuts!) It's hard to figure out the frequency of the oscillation as it seems to be across a band not too far above the audible range. The zobel resistor stays completely cool which indicates this is not a truly HF oscilation.

With only one set of output devices (and the rails lowered with a variac) there was no sign of this - I couldn't even induce oscillations by putting caps across the dummy load. This of course suggests I am dealing with oscillations stemming from the CFB topology.

Any ideas would be appreciated.
  Reply With Quote
Old 29th January 2004, 10:42 AM   #2
diyAudio Member
 
Circlotron's Avatar
 
Join Date: Jun 2002
Location: Melbourne, Australia
My guess is that there is a low capacitance from unearthed heatsink to ground and a somewhat higher capacitance from collectors (i.e. signal) to heatsink. With the heatsink floating there is not enough capacitance for much effect but when it is grounded the larger capacitance comes into play.

Have a careful look just exactly where you are earthing it to. Is it injecting currents into a low signal level earth area?
__________________
Best-ever T/S parameter spreadsheet.
http://www.diyaudio.com/forums/multi...tml#post353269
  Reply With Quote
Old 29th January 2004, 10:56 AM   #3
diyAudio Member
 
jan.didden's Avatar
 
Join Date: May 2002
Location: Great City of Turnhout, Belgium
Blog Entries: 7
I agree with Circlotron. Assuming the collectors are the signal output, you may try to gnd the heatsink and connect the two collectors by a smallish (10-20pF ) cap. If the collectors are not the signal outputs but the supply connections, try to put an extra supply decoupling (.1uF) from the collectors to the central gnd, using as short leads as possible. You then effectively bypass the supply wiring inductance.

Jan Didden
  Reply With Quote
Old 29th January 2004, 02:47 PM   #4
diyAudio Member
 
Tube_Dude's Avatar
 
Join Date: Mar 2002
Location: Aveiro-Portugal
Default Re: Today's Puzzler ??

Quote:
Originally posted by sam9
This of course suggests I am dealing with oscillations stemming from the CFB topology.

Any ideas would be appreciated.
Hi Sam (Nine)

Have you put a small capacitor in paralel with feedback resistor?...if you have put disconect it!

Or for incresead stability put a litlle bigger fedback resistor (increasing the lower arm of the feedback voltage divider for the some overall gain).

Regards
__________________
Jorge
  Reply With Quote
Old 29th January 2004, 03:44 PM   #5
diyAudio Member
 
Ultima Thule's Avatar
 
Join Date: Jan 2004
Location: Koskenkorva Land
Sam9,

I dont know much about you, your posts and what you have built in the past since I'm quite new to this board, but I have some questions before I would try on giving any clue about your problem.

Could you tell if you are using MOSFET's or BJT's in the output stage?

Where does this ocsillation occur, output or upper/lower side of the transistor?

If upper/lower side of the transistor, does it occur att both sides?

What kind of resistor (if any) do you use between the transistor and output?

How does it look around the VAS?

Schematic would be most appreciated, could you post anything or draw up something simple?
  Reply With Quote
Old 29th January 2004, 05:12 PM   #6
sam9 is offline sam9  United States
diyAudio Member
 
sam9's Avatar
 
Join Date: Jun 2002
Location: Left Coast
Thanks for the feedback. When I woke this morning after sleeping on it, it ocurred to me that the structure, heatsink-silpad-transitorback, consitutes a sort of crude capacitor. This dovetails with the advice from Circlotron. I'm going to check over the grounding again and make sure it is solid and low impedance. This at an expiremental stage so its not in it ultimate permanent enclosure; instead it's set up more for quick removal/replacement so I may have gotten a bit casual about grounding.

Yes, there is a cap in parralel with the feed back resistor. That has been both helpful and rather touchy on past ocassions. Another item that came to mind when I woke up. Also reducing the gain had ocurred to me. I think these are more stop gap measures though since the amps was rock stable with only one output pair installed. I still suspect something specific to the output section.

On the the other hand putting a small cap between the output collectors is a new idea. Since there are two parrallel output pairs, do you suggest a cap across each pair or just one across the two output resitors (.22R)? The later is physically easier to arrange.

My schematic capture software doesn't export graphic images that would be of suffient resolution to be helpful. However, there topology is not innovative. IS a single long tailed pair, CC biased by two diodes which also bias the CC in the VAS, VAS is beta enhanced configuration. and output is as described. Its not an exact copy of a specific textbook or cookbook amp but there is nothing in it you wouldn't have seen before. Output devices are 2sa1943/2sc5200, drivers 2sd669/2sb649 and TO-92s are 1n5551/1n5401.
  Reply With Quote
Old 29th January 2004, 05:39 PM   #7
diyAudio Member
 
Tube_Dude's Avatar
 
Join Date: Mar 2002
Location: Aveiro-Portugal
Hi sam9!

What you mean by CFB Amp?

I have thinked that you talk about a Current Feedback Amp...but now i'm not so sure...as you talk about:

Quote:
IS a single long tailed pair, CC biased by two diodes which also bias the CC in the VAS, VAS is beta enhanced configuration. and output is as described

If it's not a current feedback design the sugestions that i gave to you in my previus post don't apply!!!
Are you talking about a Counpound feedback Pair Output Stage??(CFP).
__________________
Jorge
  Reply With Quote
Old 29th January 2004, 06:07 PM   #8
sam9 is offline sam9  United States
diyAudio Member
 
sam9's Avatar
 
Join Date: Jun 2002
Location: Left Coast
CFB = collector feedback. Output is taken off the collectors, emitters collect to rails and driver emitters commect to output collectors. It has certain theoretical advantages with respect to thermal tracking, tight local feed back (low distortion) etc, but often exhibits local oscillations there are very hard to pin down and cure. Appearently, adding parralel output pairs adds to all of the above.
  Reply With Quote
Old 29th January 2004, 06:13 PM   #9
diyAudio Member
 
Tube_Dude's Avatar
 
Join Date: Mar 2002
Location: Aveiro-Portugal
Quote:
Appearently, adding parralel output pairs adds to all of the above.
Yes because they increase the input capacity of the outputs..try to lower the resistor between base and emiter(rail) of the outputs for increased speed of the output stage.
__________________
Jorge
  Reply With Quote
Old 31st January 2004, 04:59 AM   #10
sam9 is offline sam9  United States
diyAudio Member
 
sam9's Avatar
 
Join Date: Jun 2002
Location: Left Coast
Here's the results of using everyone's suggestions:

A-(Ciclotron)Found a way to bolt the heatsinks to the tempory enclosure but still be able to quickly take the board out and replace it. This got rid of the intermittent behavior and I was left with more "normal" oscillating behavior.

B-(Tube_Dude)Removed the small cap parrallel to the feedback resistor. This greatly reduced but did not eliminate the oscillations. Odd, when I was running this with only one pair of output devices, adding this cap cleaned up the oscillations so well that even with a variety of caps across the dummy load, I was getting a beautiful, crisp output signal on the scope. Now with two pairs, removing it helps!

C- (Tube_Dude) I checked the values of the feedback resistors. Due to a typo using my schrematic capture software, I had set the gain about 20% higher than intended! Correcting this eliminated the rest of the oscillations, at least under no-load condations.

However, I still get oscillations with an 8 ohm dummy load. A big bloom of "fuzz" at the the + and - peaks when the input signal in increased to just a few mA. Increasing further and it eventually just flat-lines until the signal is brought back down. Since this seems to indicate something wrong at the peaks, I'll next try reducing the resistance in the [driver base]-[rail]-[output device emitter] path per Tube_Dude. After that comes the cruder approach of increasing the compensation cap and/or reducing gain another notch.

After this project, I think I've had enough CFB for a while the next amp is going to be an EF output. What good is squeezing out a few percent more distortion if the sucker insists on oscillating if you look at it cross-eyed?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Let's see, what did we DIY today? Magura Parts 7 5th June 2009 07:46 AM
CS800 puzzler..... unclejed613 Solid State 1 12th August 2007 10:50 PM
Puzzler krzanik Tubes / Valves 3 27th April 2007 12:47 PM
Today was the Day EdT Class D 0 14th April 2007 12:23 AM
Puzzler!! Using 3 amps w/ 1 pair speakers ransom peek Solid State 11 18th March 2005 04:50 PM


New To Site? Need Help?

All times are GMT. The time now is 10:50 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2