Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

Kenwood KR-5010 problems
Kenwood KR-5010 problems
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th February 2015, 05:01 PM   #1
taguele is offline taguele  United States
diyAudio Member
 
Join Date: Feb 2015
Default Kenwood KR-5010 problems

Hello, before you read this bear in mind I'm very new to the hobby in general

I bought this locally and assumed it would have no problems since I paid well for it (of course too much to ask, will probably go new and drop vintage next time)

Anyway, the light bulbs work but they run extremely hot (after only 20 minutes), almost to the point where it burns my hands. Didn't know it was them until I cracked it open and see the bulbs location on the very top...(design flaw?) To further prove this, you can see burn marks on the wood top panel (see pics)

So without tools is there anyway I can fix this? I'm assuming replacing the bulbs would help but I would need a good guide before I get into that.

Also there is a strong old electronic smell coming from the boards inside, unrelated to the bulb issue. It kind of smells like dried blood and stinks up my room pretty bad especially when it is on, is there any product that solves this kind of issue?

Click the image to open in full size.Click the image to open in full size.

Last edited by taguele; 27th February 2015 at 05:08 PM.
  Reply With Quote
Old 28th February 2015, 08:23 PM   #2
taguele is offline taguele  United States
diyAudio Member
 
Join Date: Feb 2015
bump
  Reply With Quote
Old 28th February 2015, 09:03 PM   #3
vzaichenko is offline vzaichenko  Russian Federation
diyAudio Member
 
vzaichenko's Avatar
 
Join Date: Jan 2010
Location: Moscow, Russia
Kenwood KR-5010 problems
Hi Taguele,

First, you need to download the service manual (register to be able to download):
>Kenwood KR-5010 service manual<

And then you will have to see what's going on there, using at least a DMM.

Cheers,
Valery
__________________
If you can't explain it simply, you don't understand it well enough (c) Albert Einstein
https://www.vzaudio.com/
  Reply With Quote

Reply


Kenwood KR-5010 problemsHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kenwood KR-5030 receiver problems flambart Solid State 4 1st May 2011 02:04 AM
Need help on Kenwood KR 7070 Motto26 Tubes / Valves 5 10th June 2009 08:26 PM
Kenwood KR-A3080 GEirin Solid State 3 18th May 2007 11:24 PM
Kenwood KR-V126R moses Solid State 2 26th September 2002 03:16 PM


New To Site? Need Help?

All times are GMT. The time now is 08:30 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki