Scott LK-60 kit channel distortion - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th December 2014, 09:02 PM   #1
diyAudio Member
 
Join Date: Jul 2009
Default Scott LK-60 kit channel distortion

I've just pulled a Scott LK-60 out of storage and upon firing it up, one channel has very low output and crackles when pushed. Interestingly, if I switch the same speakers to the "remote" outputs, the problem is the same, but reversed between the speakers (problem moves from left to right channel). Anyone have any thoughts on where to begin?
  Reply With Quote
Old 14th December 2014, 09:27 PM   #2
rayma is online now rayma  United States
diyAudio Member
 
Join Date: Apr 2011
Location: Upper midwest
Quote:
Originally Posted by sparks12kv View Post
I've just pulled a Scott LK-60 out of storage and upon firing it up, one channel has very low output and crackles when pushed. Interestingly, if I switch the same speakers to the "remote" outputs, the problem is the same, but reversed between the speakers (problem moves from left to right channel).
The remotes might be wired backwards (this was a kit), and the same circuit is still bad. Probably the output stage is blown. Do you have a schematic?

Last edited by rayma; 14th December 2014 at 09:39 PM.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SCott LK-48-B balance pot fullrangeSR Tubes / Valves 2 24th February 2010 11:01 AM
Scott LK-72A is ALIVE Vespasian Tubes / Valves 4 14th November 2006 01:45 PM
Wanted-Assembly manual for Scott LK-150 GlassAudio Tubes / Valves 0 31st December 2004 06:24 PM
Linn LK-2(60) One Channel has Failed. Anyone familiar with this circuit design? dtm1962 Solid State 0 11th April 2004 12:41 AM
Scott LK-72 kit tube amp ashok Tubes / Valves 9 29th October 2002 12:58 AM


New To Site? Need Help?

All times are GMT. The time now is 11:11 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2