Loud BUZZ from one channel on Mondial Designs home theater - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th December 2014, 08:32 PM   #1
Red360 is offline Red360  United States
diyAudio Member
 
Join Date: Dec 2014
Default Loud BUZZ from one channel on Mondial Designs home theater

Hi All..I am new here and pretty new to the anything audio to be honest.
Have a decent vintage system myself but only to enjoy..never had to repair anything but the bulbs.

I recently got in a Home Theater system (from the '90s) that I was told was of very good quality. I really am a newbie when it comes to this stuff but am so eager to learn since I have many amps (etc) now that may need attention.

This unit is called the Amfi Theater 1 made by Mondial Designs (which was later bought by Klipsch I think).
It is an all in one..tuner, amp, pre-amp set up.

All I have found on this is the original brochure, can't find any spec sheets etc.

Problem its having:
The main speaker outputs appear to work / sound good.

The Center channel however produces only a semi loud buzz through the speaker..have tested the speakers of course but no matter what its just a constant loud buzz.

The Buzz does not change with the volume either, or no matter what I change on the unit..constantly the same.

I haven't been able to get sound from the surround outputs but not sure of the settings yet and didn't really want to keep it running.

Also to note...The rear of the unit it has a switch named Center Mode
This has three settings..normal, wide and phantom (off)..none of those settings change a thing either.

Questions:
I am in a very small town and the only person around to work on this will want more than I can even afford right now for the estimate alone.

Is there anything I can test with my multi meter to start with?

I really don't know much (if anything) about this kind of stuff..but I do know how to be careful, how to take things a part and how to learn if I know the right terms and what to search for.

Terms and "how to's" I know thus far are pretty basic:
- Caps, I know how to visually look for bad caps (metal kind)
- Bad solders, I can look for those but very new to it
- Fuses, this board has several that all check out as good
- I know what the power supply is..but not much else.

Thank you in advance.
Attached Images
File Type: jpg IMG_3335.JPG (633.0 KB, 19 views)
File Type: jpg IMG_3343.JPG (614.3 KB, 14 views)
File Type: jpg IMG_3344.JPG (586.4 KB, 12 views)
File Type: jpg IMG_3337.JPG (491.9 KB, 13 views)
File Type: jpg IMG_3345.JPG (478.4 KB, 11 views)
File Type: jpg IMG_3338.JPG (639.9 KB, 5 views)
File Type: jpg IMG_3346.JPG (443.0 KB, 5 views)
File Type: jpg IMG_3339.JPG (644.4 KB, 6 views)
File Type: jpg IMG_3347.JPG (588.3 KB, 6 views)
File Type: jpg IMG_3340.JPG (622.8 KB, 7 views)
  Reply With Quote
Old 17th December 2014, 12:10 AM   #2
Red360 is offline Red360  United States
diyAudio Member
 
Join Date: Dec 2014
I just got in the two new medium sized (3300uf 50v) capacitors I ordered...soldered them in and it works great
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
16 Channel DAC for home Theater? msgarris Digital Line Level 2 31st May 2014 10:47 AM
Aragon 24K sp PreAmp by Mondial Designs, possiblity for component/wiring upgrades? babylondrifter Solid State 1 8th January 2014 04:05 AM
5.1 Channel Chip Amp/Gainclone for Home Theater Buddie Chip Amps 117 22nd February 2011 02:01 PM
home theater with 2 channel preamp bonsai171 Solid State 1 3rd June 2006 12:28 PM
New designs -> ML-TQWTs for TangBand W3-871S in a home theater youyoung21147 Full Range 3 1st September 2005 10:10 AM


New To Site? Need Help?

All times are GMT. The time now is 05:26 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2