DIGI-125 Kit Amplifier Module - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th March 2002, 06:43 PM   #11
palesha is offline palesha  India
diyAudio Member
 
Join Date: Nov 2001
Location: Pune India
I am thinking to use digi - 125 as subwoofer amp. Then shall we reduce the bandwidth of the amp or any other suggestions to get better bass response. This will help us to use it in more applications.
Mahendra Palesha
  Reply With Quote
Old 28th March 2002, 10:24 PM   #12
diyAudio Member
 
Join Date: Sep 2001
Location: Sth. Oz
I was introduced to this circuit by a techo friend (Thanx Mark!)who had built a number of these for his own and for a TV station where he worked. Like you I was attracted by it's simplicity so I bought an original kit of parts including the tiny PCB. It is very easy to build though the postage stamp size PCB is a bit of a nightmare because of it's size and close proximity of everything not to mention the almost hairline fine tracks. There is a bigger and in my view better PCB available from "R.C.S. Radio Pty.Ltd" email: rcsradio@cia.com.au
Postal Address: 651 Forest Rd, Bexley, NSW. 2207 Australia.
I built this into an old amp that I gutted except for the PS which gives about 29 volts. The first version I built with the 2n3055/2n2955 which seemed to work fine and did not sound too bad. Following a discussion with the designer (he's a local here in Adelaide, Sth Oz) he suggested I try the MJ 802/4502 pair which I found a definite improvement, losing what to my ears was a touch of graininess with the original devices. Laterly I have been running the boards with the (I think) Toshiba 2sa1227a/2sc2987a pair which I believe are very linear. Unfortunately I can't draw conclusions as to which was the better sounding because of the time between the last two versions only to say I have not had any problems using them to drive any speakers and they sound nice and clear and open to my ears. Considering the cost I think it is a nice little unit to use or experiment with. I should also add that from the beginning I have used it only at line level through a selector switch and vol pot and it seems to be to me anyway, for the time being, enough.
  Reply With Quote
Old 29th March 2002, 02:41 AM   #13
sonnya is offline sonnya  Denmark
diyAudio Member
 
sonnya's Avatar
 
Join Date: Oct 2001
Location: Denmark
Is it me... or is this amp runing purely class B in the output stage?.
A bias of 2 diodes = ~ 1.6 volt and you need around the double (2.4 .. 3.2V)to keep a idlecurrent runing thru the output pair based on the schematic shown.
It should have more like 4 - 5 diodes in series.

I think 1N914 is a normal switching diode like the 1N4148?

Sonny
  Reply With Quote
Old 29th March 2002, 07:21 PM   #14
diyAudio Member
 
Join Date: Sep 2001
Location: Sth. Oz
I guess you must be right as in it's standard form the heatsinks hardly warm up. I did try it with 4 diodes and this certainly pushed the ouput devices harder into class A. The heatsink I use is quite substantial and it did get quite hot as well as the PS tranny so I went back to three diodes for safety sake. Now it just gets warm, but only after a long period and only when it gets pushed hard...
  Reply With Quote
Old 17th May 2002, 10:26 PM   #15
diyAudio Member
 
Join Date: Sep 2001
Location: Sth. Oz
Since my last post interest in this amp (the circuit posted by Palesha above) seems to have waned.

As I wrote in my post it is not a bad sounding circuit easy to build and quite compact and amenable to using it with various devices.

As a consequence and following on from comments about the sonic differences between o/put devices on the AKSA site, my friend Mark (he's the one with the knowledge) suggested we try the Toshiba 2SC5200/2SA1943 devices as used in the AKSA amp and as a future upgrade, replace Q3/Q5 (garden variety BC546's) in the above circuit with the MJ15030, and Q4 (BC556) with the MJ15031, which are inherently more linear.

Has anybody any comments/suggestions?, and has anyone tried to simulate the above circuit to see how it compares with others?

As I said earlier, it isn't a bad sounding circuit, quite reasonable as a matter of fact compared to my old Sony V-Fet 4650.
We would wellcome any comments, suggestions...

Cheers,
tomcat
  Reply With Quote
Old 18th May 2002, 10:44 PM   #16
diyAudio Member
 
Join Date: Sep 2001
Location: Sth. Oz
Well, wouldn't you know it, it poured down all day yesterday and although I didn't actually plan to do it so soon I pulled my "Digi-125" out of the rack and replaced the 2sc2987/2sa1227 ouput devices with the Toshiba 2sc5200/2sa1943 as used in the AKSA...
The result?, in my humble opinion it is huge! Everything Hugh Dean said of these devices is true. The bottom end is fuller and more 'rounded' for want of a better description, though relatively accurate. The mids seem more airy or open though I can't comment precisely about the top as I haven't played any classical stuff yet as my time was limited but it does sound good... Almost as good as my Fisher X-100 A, albeit with more power...
A very worthwhile improvement thanks to this forum...
tomcat
  Reply With Quote
Old 20th May 2002, 12:57 PM   #17
AKSA is offline AKSA  Australia
diyAudio Member
 
Join Date: Sep 2001
Location: Melbourne, Australia
Hi Tomcat,

Yes, interesting feedback, my thanks to you for letting us know.

Syl recently commented that the perception of bass control was a function of the output devices and their choice. This seems to confirm your experiences too, and certainly mine.

These transistors are extremely linear, with beta flat from 100mA to 7A. They are also fast, with tiny parasitic capacitances, particularly base/collector, the BIG ONE.

When a bipolar transistor has tiny electrode capacitances, it is very fast, and the storage of minority carriers is minimised. These create 'memory' effects, where the dynamics of real time signals are influence by what has passed before. This is sometimes called 'time smear distortion', and tends to muddy the sound.

Parasitics change depending on the collector/emitter voltage at the time. This complicates things still further. Obviously, the higher the voltage rating, the faster the chip and the lower the capacitances, the better. That's the reason the 5200/1943 is such a good choice for audio.

Cheers,

Hugh R. Dean
www.printedelectronics.com
  Reply With Quote
Old 20th May 2002, 11:52 PM   #18
diyAudio Member
 
Join Date: Sep 2001
Location: Sth. Oz
Yes, it was akin to hot rodding the amp. Thanks to you and Graham Dicker who designed the Digi-125 and made it so easy to build and tweek. I had more time yesterday to listen and one of the things I found is the speakers virtually disapear. I have a pair of Spendor Preludes, the forerunner of the SP/2, so they aren't up there with the better Spendor's, but they do sound nice. The sound was relatively box bound previously, but now it's out in front and all around the boxes and between, a remarkable transformation, I always blamed the speakers, but now there is a wonderfull soundstage almost independent of the speakers, whereas before it was plain ol' boring L & R with what was left over in between! Even CD's I found unlistenable before have found a new lease of life! This has encouraged me to definitely do some more tweeks by replacing the BC546 devices with the MJE 15030 and the BC556 with the MJE 15031. I have already played around with the NFB by increasing the value of the resistor and an extra diode to push it a bit harder into class A, so my next step will be to lash out on dome decent resistors in the circuit which by choice was carbon film as I don't like the sound of the cheap Taiwanese metal film, for some Tantalums as there is only a handfull so it's not going to be earth shatteringly expensive to do, but now I think will be worthwhile.
Thanks again Hugh!
tomcat
  Reply With Quote
Old 20th June 2002, 10:46 PM   #19
diyAudio Member
 
Join Date: Sep 2001
Location: Sth. Oz
Ok, so here's the score for those who are interested in my quest to "Hot-Rod" my Digi-125, or their own. You are also no doubt aware of another thread I started in the quest to find out the sound quality differences between devices, (and many thanks to all those who contributed advice and tips on that forum) so I guess this is pertinent to that in some way.

I'm not very good at elaborating but here is how my quest turned out so far;

The first devices that I changed were the outputs to the Toshiba 2SC5200/2SA1943 as I reported previously. This brought about a substantial change that was noticable immediately and a definite improvement in sound quality compared with the previous op devices. At this point the driver transistor Q3 (ref to schematic posted by Palesha on prev. page) was a BF469 as I had changed it some time back due to the fact that the little BC546 that was designated for that spot constantly ran hot due to the current going through it and in danger of it going pop eventually as it has once in the past. I have tried several other devices in this spot (MJ340/2N3019) but they all sounded indifferent and the amp lost it's transparent and sweet sound quality with these when used with the Toshiba op's.
I had thought of trying the MJE1530/1531 devices in place of the BC556 & BC546 specified for Q4 & Q5, but in the end I used the Toshiba driver transistors 2SA1837/2SC4793 instead, which was a total waste of time as the soundstage just collapsed along with the openess and clarity which I found so beguiling and revealing. Back went the BC546/556 devices and everything was as before, sweet detailed and transparent.
In hindsight perhaps I should have tried MJE 15030/1531 devices, but because I'm a cheapskate I opted instead for the Toshiba ones... Perhaps at a later date...
In any event the sound quality to my ears is exceptional, transparent, detailed and sweet, though there was a mild disconcerting something in the sound (a little harshness/grain perhaps) which I could not put my finger on. In the event this problem disapeared when on a whim, which proved fortuitous, I changed the compensation cap on Q3 (BF469) from 150pF to 68pF to see what would happen. Well, that touch of grain, or whatever it was disapeared. The sound quality was more ballanced and if possible even more open. For instance on KD Lang's CD "All You Can Eat" on the first track, "If I were you", you can clearly hear the backing chorus which was almost indistingiushable from Lang's main vocals previously, not just on the Digi but other amps as well...
In conclusion anyone contemplating building a Digi-125, replacing the output devices Q6 & 7 with the Toshiba 2SC5200/2SA1943 and the driver Q3 with the BF469 along with the compenstion cap to 68pF is very worthwhile and effective. Oh and I almost forgot, put an extra diode in with the existing two shown on the circuit, and you will have an amp that is remarkably fast, transparent, and one that will make your speakers sound like electrostatics...
cheers,
tomcat
  Reply With Quote
Old 20th June 2002, 11:14 PM   #20
diyAudio Member
 
schizeckinosy's Avatar
 
Join Date: Jun 2002
Location: Gainesville, FL
This looks like a good project for a multi-channel amp.

Would it be safe to run this from 38V rails? Apexjr has some 27V toroids for a good price.

Thanks, Dan
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sub Amplifier Module Manufacturers schmeet Subwoofers 6 4th October 2011 04:23 PM
Got 2x65VAC PS, any idea on DIY amplifier module? barco Solid State 2 24th October 2008 06:31 AM
Help me troubleshooting amplifier module fosforo Solid State 15 7th November 2006 11:59 AM
Equilog PWM amplifier module? TroelsM Class D 7 12th November 2005 12:32 AM


New To Site? Need Help?

All times are GMT. The time now is 05:32 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2