BAT VK-500 Need help!!! - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd November 2014, 02:58 AM   #1
diyAudio Member
 
Join Date: Nov 2012
Location: Brasil
Default BAT VK-500 Need help!!!

My BAT VK500 does not work the left channel.
Is a dual mono design using only n-type mosfet (24 per side)
It has 2 green lights that when it's off shows that there is a problem with the amp, so that's the case.
So I changed the two fuses that were blown and it starts, after 2 minuter goes off.
A resistor blow away, the R16, I do not know what is the value, sorry I'm not a technician.
My technician changed the resistor (he said that is a kind of circuit protection resistor) to other one, and started again... nothing worked.
So he examined the mosfet section and noticed that 2 mosfets were bad, changed the mosfets and the resistor of each, also the R16 resistor and the amp worked for 30 minutes very fine, very cool.
After that stopped again, he looked for the mosfets and one of the new changed was bad. Changed again, changed the resistors, ie... worked fine for some time.
I brought it to my home, turned on and wait, after one hour, the left channel became very, very hot, it stopped again, I open iit and saw the resistor blown again.
Please give me some indication to tell to my technician, here were I live there is no information and the service is very stupid.
  Reply With Quote
Old 23rd November 2014, 03:07 AM   #2
diyAudio Member
 
Join Date: Nov 2012
Location: Brasil
Also, if these two problem mosfets are removed, and the amp work only with 22 mosfets, the problem disappears, in the last case I will adopt this.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BAT VK-32SE Cobra2 Analog Line Level 0 1st February 2014 07:06 PM
BAT Vk-500 schematics info?? Zero Cool Solid State 0 2nd January 2012 08:24 PM
Bat Vk-60 Tyimo Tubes / Valves 1 10th October 2008 09:48 PM
BAT VK schematic needed Yarpen Solid State 0 31st March 2007 10:50 AM
Question about BAT VK 75 felixx Tubes / Valves 0 1st May 2005 01:38 PM


New To Site? Need Help?

All times are GMT. The time now is 09:27 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2