Just brought the arcam fmj a32 but get really load popping from the channel left is f - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th September 2014, 07:29 PM   #1
youngie is offline youngie  United Kingdom
diyAudio Member
 
Join Date: Jan 2012
Default Just brought the arcam fmj a32 but get really load popping from the channel left is f

Just bought the arcam fmj a32 but I am getting really loUd popping from the right channelis but left channel is fine,,, the power amp is all good too..... Making a really big load bang there is music behind the bang thou... Can anyone help kind regards lee

Last edited by youngie; 18th September 2014 at 08:17 PM.
  Reply With Quote
Old 18th September 2014, 07:45 PM   #2
llwhtt is offline llwhtt  United States
diyAudio Member
 
Join Date: Jun 2008
Location: SoCal
You might to read what you wrote because it doesn't make much sense. Brought or bought? Where did you bring it? Load or loud? Channel left is fine?

Craig
  Reply With Quote
Old 18th September 2014, 08:50 PM   #3
youngie is offline youngie  United Kingdom
diyAudio Member
 
Join Date: Jan 2012
Any ideas anyone please
  Reply With Quote
Old 18th September 2014, 08:51 PM   #4
Bare is offline Bare  Canada
diyAudio Member
 
Join Date: Dec 2001
Location: vancouver
It's Broken? :-) Send it in to the factory for patching.
With luck it won't double your purchase price.
Frankly I'd tread lightly on further expenditure though, likely you've already seriously overspent on it.
  Reply With Quote
Old 18th September 2014, 08:52 PM   #5
llwhtt is offline llwhtt  United States
diyAudio Member
 
Join Date: Jun 2008
Location: SoCal
When does it make the popping sound? At turn on, turn off, all of the time? Does it vary with the volume control?

Craig
  Reply With Quote
Old Yesterday, 10:38 AM   #6
youngie is offline youngie  United Kingdom
diyAudio Member
 
Join Date: Jan 2012
When I plug right speaker in. Just a really load banging noise all the time.. Does not get any loader when turning up the volume. Music is playing as it should be but. The popping or banging is at every second.. Thank you all for there help.
  Reply With Quote
Old Yesterday, 11:10 AM   #7
diyAudio Member
 
KatieandDad's Avatar
 
Join Date: Nov 2011
Location: UK
As you are in the UK, find a local Arcam specialist repairer.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crackling noise from left channel of my Arcam CD23 andy2 Digital Source 8 7th March 2013 04:14 PM
Arcam fmj a22 it go bang errol8000 Solid State 9 31st May 2011 09:46 AM
Arcam Alpha 3 Left Channel broken... wprice99 Solid State 148 13th May 2008 05:56 PM


New To Site? Need Help?

All times are GMT. The time now is 03:22 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2