Beomaster 1900-2 restoration - manual? - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th January 2004, 12:30 AM   #1
mb is offline mb
diyAudio Member
 
Join Date: Dec 2002
Location: Singapore
Default Beomaster 1900-2 restoration - manual?

Hi,

Does anyone have the service manual to this B&O receiver, or know how I can purchase one? I've checked with most sites offering manuals for sale, and can't find one for this model.

No manual = money down the drain. I bought a lemon; I'm trying to a least get it back to life...

Thanks.
  Reply With Quote
Old 16th January 2004, 02:19 AM   #2
diyAudio Member
 
mrfeedback's Avatar
 
Join Date: Feb 2002
Location: Perth, Australia.
What's wrong with it, and can you post pics?

Eric.
__________________
I believe not to believe in any fixed belief system.
  Reply With Quote
Old 16th January 2004, 05:29 AM   #3
mb is offline mb
diyAudio Member
 
Join Date: Dec 2002
Location: Singapore
It's old, tired and when I bought it, there was an obvious hum. Shortly after, the touch senstive select would not work (ie. no power up). Thereafter, it blew an output transistor when my friend tried to check it out. Still, it looks beautiful, and to get it up and running would be great.

The previous owner obviously sent it to an incompetent for some repair.

At worst case, I was thinking of replacing he entire innards with a gainclone, but that would be such a pity.

Click the image to open in full size.
  Reply With Quote
Old 16th January 2004, 05:41 AM   #4
diyAudio Member
 
mrfeedback's Avatar
 
Join Date: Feb 2002
Location: Perth, Australia.
Sounds like you have a regulator fault in addition to the blown output transistor.
You could remove the output transistors for that channel and investigate that all pre-amp/digital supplies are up and getting to the approprite sub-boards.
Once you have done this and confirmed overall operation you could then rebuild the faulty output channel.
Put a 40W or 60W lamp in series with your 240V power whilst doing this investigation.

Eric.
__________________
I believe not to believe in any fixed belief system.
  Reply With Quote
Old 16th January 2004, 10:09 AM   #5
diyAudio Member
 
JensRasmussen's Avatar
 
Join Date: Jul 2002
Location: Denmark - Jutland
Send a message via ICQ to JensRasmussen Send a message via MSN to JensRasmussen
Default Manual

Hi,

I'll see what manuals I can find at work....

Are PDF's ok?

\Jens
  Reply With Quote
Old 16th January 2004, 09:37 PM   #6
diyAudio Member
 
Join Date: May 2002
Location: wheeling illinois
I have a 2400 which is basically the same thing except more
power. Had schematics somewhere, don't even know where
to look. B&O should be willing to sell you them however.
After you get it working again you will still have a low quality
item. The balance, bass and treble sliders get very noisy
and you will NOT be able to find replacements for them.
Much of the time one or both channels on mine cut out due
to the balance slider. B&O is gorgeous to look at, but poor
designs. Crammed into a box with virtually no room to work.
  Reply With Quote
Old 16th January 2004, 10:06 PM   #7
diyAudio Member
 
Join Date: Jan 2004
Location: Germany / Bavaria / Augsburg
Quote:
Originally posted by mb
At worst case, I was thinking of replacing he entire innards with a gainclone, but that would be such a pity.
I donīt think so.

B&O has some special optical design, that some people really like.
But from the technical point of view it is really nothing special.
A good replacement would seriously improve sound quality here.
__________________
Best Regards,
Cybergent
  Reply With Quote
Old 17th January 2004, 02:58 AM   #8
diyAudio Member
 
mrfeedback's Avatar
 
Join Date: Feb 2002
Location: Perth, Australia.
Default Learning Curve.........

Whilst I would not rate these B&O systems as high-end, for general home/family usage these work very well, the remote controls are second to none and the WAF is pretty much ultimate.

The initial hum may have been caused by a dead cap, and it sounds like your friend slipped a meter probe or something and blew an output stage.
You (and your helpful friend!) could isolate power from the output stages and then find the fault causing no power up.
There are multiple fuses in these, so that may be part of the problem.

Once you have it powering up you could connect tape outs to an external amplifier to confirm pre-amp operation.
Once power up/pre-amp operation is confirmed it should not be too hard to rebuild the output stage.
Like I said these are not fantastic hi-fi, but they do have a sound quality different to anything Japanese, and they are nice to live with.

Good luck, Eric.
__________________
I believe not to believe in any fixed belief system.
  Reply With Quote
Old 23rd January 2004, 07:19 AM   #9
mb is offline mb
diyAudio Member
 
Join Date: Dec 2002
Location: Singapore
Thanks for your comments and suggestions.

Jens & Kevin, any luck locating the manuals? PDF will be just fine. Send me a PM, and I'll reply. I'm quite aware that the ultimate quality of a repaired BeoMaster won't come close to my AKSA or gainclone, but I thought that it would be an interesting exercise. If this search for the manual really needs to nothing, I'm ready to look at re-using the fairly hefty toroidal transformer as a basis for a Jacob Jensen GC!

Thanks,
mb
  Reply With Quote
Old 31st July 2005, 09:11 AM   #10
NinaK is offline NinaK  Norway
diyAudio Member
 
Join Date: Jul 2005
Location: Norway
Default Manuals for 1900

I have one for Beomaster 1900 type 2903, though I'm not sure if it's complete. But I can send it to you, so you can see for yourself.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pre-amp for BeoMaster esims89 Tubes / Valves 4 26th November 2008 12:57 AM
B&O Parts - Beomaster 1900 Terryphillip Solid State 6 17th February 2007 09:35 AM
SL 1900 and antiskating? TroelsM Analogue Source 8 12th January 2007 11:55 AM
Mac 1900 pre amp starting mute problem wleediy Solid State 0 8th October 2004 08:04 PM


New To Site? Need Help?

All times are GMT. The time now is 07:56 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright Đ1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2