"Mysterious" wire in Krell KSA-50MkII - Page 4 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th July 2014, 01:51 PM   #31
diyAudio Member
 
Join Date: Aug 2005
IT could be a switch for Btl Mode Operation. This would explain only one wire from left Output via a resistor and a switch to the right input
  Reply With Quote
Old 25th July 2014, 09:34 AM   #32
diyAudio Member
 
Join Date: Nov 2010
This sounds like the only reasonable explanation! If it had something to do with grounding or feedback then the switch would've been a bit pointless.

To be honest I never knew that KSA could actually be bridged as Krell always had separate monoblock amps - the KMA's.
  Reply With Quote
Old 30th July 2014, 11:16 AM   #33
diyAudio Member
 
Join Date: Nov 2010
So now when the wire mystery is solved, can anyone tell me what to replace the old ROE's in the negative feedback loop with?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"WTB" "The Wire AMP" Class A/AB Power Amplifier based on the LME49830 with Lateral enantra Swap Meet 3 23rd December 2012 06:36 PM
Building "The Wire AMP" Class A/AB Power Amplifier" wirewiggler Solid State 12 23rd September 2012 03:40 PM
Krell S300i Integrated Amp "Made in China" which Factory? tiefbassuebertr Solid State 10 29th October 2011 09:17 AM
Need help to build "Krell KSA-50" space2000 Solid State 12 7th August 2008 01:53 PM
Any thoughts on these mysterious OEM 8" woofers? Spasticteapot Subwoofers 4 21st January 2007 12:25 AM


New To Site? Need Help?

All times are GMT. The time now is 12:26 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2