Service CAV A8M - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State
Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th July 2014, 11:37 AM   #1
diyAudio Member
 
east electronics's Avatar
 
Join Date: Jan 2006
Location: Athens GREECE
Default Service CAV A8M

Doesnt happen very often so those who did it deserve the credit .

The CAV A8M comes into the shop badly burned since the costumer plays in the rough side i think probably too loud with heavy loads while the amplifier has been repaired ( badly also ) previously

Inside the notorious SAP 15-P-N inside a circuit that proper balance is very important to achieve stability .Seems that the amplifier has been repaired in the past more than once , probably by the local distributor , and wears inside all shorts of available versions of SAP 15 ...Obviously this is not the way to achieve stability .


On factory though the quality of make , order , symmetry and arrangement on the boards is exceptional for this type of product .After a quick argument with the local distributor who claimed that he never had a schematic a quick phone to Jenny and Ken proved to be a walk in the park and before i hung up the schematic was in my inbox .

That is a service minded company and in the feature i will never question getting a CAV product Already have a pair of speakers that i am thrilled with .

Well done Ken , Jenny thanks to your service minded policy the A8M is up and running again !

In between enjoy some pictures of the repair ...
Kind regards
Sakis
Attached Images
File Type: jpg DSC02629.JPG (98.1 KB, 57 views)
File Type: jpg DSC02630.JPG (98.4 KB, 55 views)
File Type: jpg DSC02631.JPG (101.9 KB, 51 views)
File Type: jpg DSC02647.JPG (494.6 KB, 50 views)
File Type: jpg DSC02648.JPG (129.6 KB, 44 views)
File Type: jpg DSC02649.JPG (119.4 KB, 30 views)
File Type: jpg DSC02650.JPG (123.6 KB, 24 views)
File Type: jpg DSC02651.JPG (127.5 KB, 22 views)
File Type: jpg DSC02652.JPG (383.1 KB, 29 views)
__________________
SERVICE ΕΝΙΣΧΥΤΩΝ ΚΑΙ ΙΑΠΩΝΙΚΩΝ ΜΗΧΑΝΗΜΑΤΩΝ ΗΧΟΥ www.eastelectronics.gr
  Reply With Quote
Old 24th February 2016, 04:56 AM   #2
diyAudio Member
 
Join Date: Feb 2016
hi dude i have the same problem on mine ...did i have the shematics of the amplifier???
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting BIG hum problem. CJ CAV-50 Cassiel Tubes / Valves 24 22nd June 2012 02:55 PM
Sowter Service jackinnj Analogue Source 0 14th September 2010 01:00 AM
Morel CAV-938, anybody uses them? trummis Multi-Way 0 5th January 2009 11:13 PM
Service of electronics..... Lyra Everything Else 3 15th November 2004 02:23 AM


New To Site? Need Help?

All times are GMT. The time now is 03:21 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Copyright 1999-2016 diyAudio

Content Relevant URLs by vBSEO 3.3.2
Wiki