Marantz 19 Receiver Bias Problem. - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th June 2014, 11:16 PM   #1
diyAudio Member
 
Join Date: Aug 2006
Default Marantz 19 Receiver Bias Problem.

I usually can fix anything. One channel biases perfectly the other channel has only 2mv of bias and does not respond to any change in the bias control.

I have checked almost every part.

The bias transistors on the good channel get very warm. On the bad channel they act like no current is being drawn.

I have a checked the string of output transistors that are biased and they are all good. The ampllifer plays just fine but very low bias.

The collector of q1204 is about .3 volts when it should be 1.2v

The collector of q1206 is about .7 volts when it should be 1.2v.

The collector of q1205 is at 38 volts when it should be at 2.5 to 10 volts
I checked q1205 and it tests fine.

The collector of q1208 should be at zero volts and it is at 7.6 volts.
I checked q1208 and it tests fine.

I am totally stumpted and am tempted to send it to a maranatz expert.

Thought I would give you guys a shot first.

Maybe someone could give me a procedure that might isolate the problem.

I will attach schemtics as soon as I can.

Help!!!!
  Reply With Quote
Old 20th June 2014, 11:21 PM   #2
diyAudio Member
 
Join Date: Aug 2006
Default Schematics

See Schematics
Attached Files
File Type: pdf 0 (2).pdf (167.3 KB, 18 views)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Raising bias on Marantz SR4200 AV Receiver Andersonix Solid State 3 19th November 2012 10:15 PM
Marantz Model 19 Service Manual grant_MH Solid State 0 31st March 2009 02:30 AM
Marantz SR7200 receiver - problem with front 2 channels willick Solid State 1 28th July 2008 03:20 AM
Stumped - Hum / Bias Problem in Marantz 510M iso_510M Solid State 8 29th January 2008 09:35 PM
Help! Problem in My Receiver - Marantz RS685 RaymondQ Solid State 1 13th February 2004 10:22 AM


New To Site? Need Help?

All times are GMT. The time now is 06:43 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2