Faulty JVC MX-GC5 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th April 2014, 08:34 PM   #1
diyAudio Member
 
Join Date: Apr 2014
Default Faulty JVC MX-GC5

I have had my JVC MX-GC5 for a while and it recently stopped working. I can't find any evidence of blown parts. The display will partially light up when I power it up, but after 5 seconds or so it shuts off on its own. Any ideas what could cause this, I'm still learning about most of the components and could use help analyzing everything.
  Reply With Quote
Old 19th April 2014, 04:00 AM   #2
diyAudio Member
 
ostripper's Avatar
 
Join Date: May 2008
Location: Albany , NY (smallbany)
Compact stereo with chip amp. (NOT 300-500W !!)... stupid PMPO
deceptive rating.

Sears no longer sells the whole amp assembly. Finding a schematic
would tell you what IC is the amp . It might be a common cheap
LM-xxxx or TA-xxxx).

Any assembly would cost as much as a new unit , IC just 5-10$.
PS- I find these units "at the curb" often , steal the trafo/caps
before final disposal ..... look for E- waste , you might find one.
Edit - it also could be the 7805/7905/7812 regulator IC's (sears or mouser have these).

OS
__________________
Mongrel website , always current and updated :
http://www.fidelityforce.com/ostripper
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yamaha mx-1000 moeskoeri Solid State 6 29th July 2013 04:54 AM
Hi, new in this land from Mx julio c Introductions 4 16th November 2012 07:43 PM
JVC TT71/JVC QL-7 quality and price Kjeldsen Analogue Source 0 25th September 2012 07:25 AM
MX sub question carshateme Subwoofers 2 30th September 2011 11:22 PM
denom pma250 amp faulty,but no faulty parts found please help homertooties Solid State 1 7th December 2008 03:58 PM


New To Site? Need Help?

All times are GMT. The time now is 03:16 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2