Proton AA1660 switch issue - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th April 2014, 03:13 PM   #1
KTnC is offline KTnC  United States
diyAudio Member
 
Join Date: Mar 2014
Default Proton 6 ch AA1660 diagram

It seems to have become a bit of rare beast for a 1990's amp.I bought on the cheap knowing someone did some jumps on the board.It looked like they just did some input switch rerouting. Now that I got into it I need to check some original component values.

Last edited by KTnC; 20th April 2014 at 03:40 PM. Reason: new information
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Proton am-30 cicottino Solid State 4 18th November 2012 04:42 PM
Proton D940 Help mattnz Solid State 0 29th March 2010 09:39 AM
proton am200 diymax62 Solid State 6 26th June 2009 05:21 PM
proton 930 dshambala Solid State 0 7th November 2008 03:42 PM
onkyo selector switch issue lbreevesii Solid State 0 28th March 2006 09:33 PM


New To Site? Need Help?

All times are GMT. The time now is 08:09 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2