Repair help needed - Creek Destiny - Page 10 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State
Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th July 2014, 08:34 AM   #91
diyAudio Member
 
east electronics's Avatar
 
Join Date: Jan 2006
Location: Athens GREECE
Yeap The schematic is available i can email it to you or anyone else needs it for private use ...
As about the difference between the two amps i dont have any idea since i have never repaired any 5350 and also i have been repairing the destiny without a schematic ...

Schematic come much later ....

Kind regards
Sakis
service@eastelectronics.gr
__________________
SERVICE ΕΝΙΣΧΥΤΩΝ ΚΑΙ ΙΑΠΩΝΙΚΩΝ ΜΗΧΑΝΗΜΑΤΩΝ ΗΧΟΥ www.eastelectronics.gr
  Reply With Quote
Old 8th July 2014, 01:33 PM   #92
diyAudio Member
 
east electronics's Avatar
 
Join Date: Jan 2006
Location: Athens GREECE
There is one more Creek Destiny amplifier that joined us this morning with similar problems

To the list i will have to add
---mains fuse holder was kinda loose
---D23 located next to U1 that is the current monitor of the amplifier. Faulty diode was driving the amp to protection mode

All diodes in both IC have been replaced

List is getting tooooooo looooong
__________________
SERVICE ΕΝΙΣΧΥΤΩΝ ΚΑΙ ΙΑΠΩΝΙΚΩΝ ΜΗΧΑΝΗΜΑΤΩΝ ΗΧΟΥ www.eastelectronics.gr
  Reply With Quote
Old 10th July 2014, 08:29 PM   #93
jomor is offline jomor  Greece
diyAudio Member
 
jomor's Avatar
 
Join Date: Feb 2004
Location: Athens
It is great news that you are gaining repair experience on the Destiny. Mine could have been next on your list to be serviced, but I have sent it to the manufacturer 3 months ago. I got a reply a month later that the repair is in progress, but I haven't got any news sine then, despite my emails and I am getting really anxious..
  Reply With Quote
Old 12th July 2014, 03:44 AM   #94
diyAudio Member
 
Join Date: Apr 2010
Location: Coffs Harbour
Quote:
....I have sent it to the manufacturer 3 months ago. I got a reply a month later that the repair is in progress, but I haven't got any news sine then...
3 months at the manufacturer's service centre? That seems like your amplifier has been sent to the original manufacturing plant or is awaiting unobtanium parts from there. Nobody leaves work "in progress" for longer than the backlog of work takes - If there is such a long backlog, obviously more staff are needed. - really disgraceful performance from any manufacturing organisation.
__________________
Ian
  Reply With Quote
Old 17th July 2014, 10:17 PM   #95
jomor is offline jomor  Greece
diyAudio Member
 
jomor's Avatar
 
Join Date: Feb 2004
Location: Athens
I emailed them on June 2, June 27 and July 17. Still no reply. I will have to call them to find out what is happening with my device, I hope this will not develop to another horror story.
  Reply With Quote
Old 18th July 2014, 08:27 AM   #96
diyAudio Member
 
east electronics's Avatar
 
Join Date: Jan 2006
Location: Athens GREECE
One thing that is not clear to me .
Is your amplifier to be serviced in the local distributor service or its shipped to the manufacturer ?
__________________
SERVICE ΕΝΙΣΧΥΤΩΝ ΚΑΙ ΙΑΠΩΝΙΚΩΝ ΜΗΧΑΝΗΜΑΤΩΝ ΗΧΟΥ www.eastelectronics.gr
  Reply With Quote
Old 18th July 2014, 08:52 AM   #97
jomor is offline jomor  Greece
diyAudio Member
 
jomor's Avatar
 
Join Date: Feb 2004
Location: Athens
I have shipped just the final stage board to the manufacturer (Creek U.K.). The local distributor had just replaced the mosfets when the amplifier failed for the first time during the first month of purchase on 2009 (εντός εγγύησης). After the first fix the amplifier played ok (actually only for a few hours since I was rarely using it) until it failed again some months ago. Since the problem reappeared I decided to send it back to the manufacturer with the hope of getting luckier this time.. If you remember I had sent you a pm on another forum asking if you had a repair manual months ago but you didn't have any Destinies repaired then. I just hope I get the board back either it is fixed or not.
  Reply With Quote
Old 19th April 2015, 09:20 PM   #98
clm is offline clm  Portugal
diyAudio Member
 
Join Date: Feb 2013
Quote:
Originally Posted by east electronics View Post
Yeap The schematic is available i can email it to you or anyone else needs it for private use ...
As about the difference between the two amps i dont have any idea since i have never repaired any 5350 and also i have been repairing the destiny without a schematic ...

Schematic come much later ....

Kind regards
Sakis
service@eastelectronics.gr
Hello Sakis
Is possible you send me the schematic diagram for Creek Destiny 1 amplifiier ?
I have a Creek Destiny with faulty, and the repair it is complicated.

Thanks
  Reply With Quote
Old 13th January 2016, 12:39 PM   #99
jomor is offline jomor  Greece
diyAudio Member
 
jomor's Avatar
 
Join Date: Feb 2004
Location: Athens
Update: The manufacturer did not repair my board but sent me another working one some months ago fortunately. Destiny_1 boards are not available and hard to find new, used or refurbished. I only tried it two or three times since then and seems to work ok. The problem is that I am not feeling relaxed to hearing music any more with this amp, since I am afraid that something might happen again..
  Reply With Quote
Old 13th January 2016, 12:55 PM   #100
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Its been a while

Pleased to hear you got a working amp in the end although I can't advise you on what to do next. I understand your worries but maybe you have to look beyond that and just enjoy the amp if you really like the sound it produces. If your never going to be happy then sell it now. Only you can make that choice.
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Repair help requested - Creek 4240SE wutzacircuit Solid State 20 19th March 2015 11:49 PM
amp repair help needed light0070702 Car Audio 18 22nd May 2013 02:42 AM
hp8903a repair needed joustman Equipment & Tools 5 7th May 2013 01:09 PM
WANTED: Creek Destiny POWER Amplifier (UK) dynoPort Swap Meet 3 4th April 2012 03:40 PM
Amp repair help needed. contaxchen Tubes / Valves 2 11th July 2005 10:22 PM


New To Site? Need Help?

All times are GMT. The time now is 07:12 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Copyright 1999-2016 diyAudio

Content Relevant URLs by vBSEO 3.3.2
Wiki