Has any one built this 1KW amp? - Page 3 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th January 2004, 12:02 PM   #21
diyAudio Member
 
Workhorse's Avatar
 
Join Date: Dec 2004
Default REPLY

IN terms of power consumption ur rite
I say AGAIN THE CHOICE IS URS!
  Reply With Quote
Old 14th January 2004, 12:11 PM   #22
diyAudio Member
 
Join Date: May 2001
Location: Bangalore, India
Quote:
2400watt amp may require a 4000watt power supply.. which means 3 phase power
Valid point. So I'll go with 1200 watts in bridged mode into a nominal 4 ohm load. Damping will be halved and slew rate will be doubled. But if the amp already has a high damping factor, this should not be an issue.

Reliability is of utmost importance. So whatever protection is desirable ought to be incorporated.

So let's proceed. I guess there are many who might join in this venture.
__________________
Sam
  Reply With Quote
Old 14th January 2004, 12:17 PM   #23
diyAudio Member
 
Workhorse's Avatar
 
Join Date: Dec 2004
Default Reply

NOW
ITS TRUE SPIRIT OF DIYERS AWAKENING!

Go on go on and have true fun
  Reply With Quote
Old 14th January 2004, 12:41 PM   #24
diyAudio Member
 
Workhorse's Avatar
 
Join Date: Dec 2004
Default Reply

SO decide guys what can I do for u

+-120VDC Rails or Bridging at +-75VDC
  Reply With Quote
Old 14th January 2004, 12:56 PM   #25
diyAudio Member
 
Matttcattt's Avatar
 
Join Date: Feb 2003
Location: Bristol
could this amp run at +/-115vDC? if i take 230vAC mains, without a transformer, it would bhe easy to get this voltage.
__________________
If it aint broke, don't fix it. If it is broke, fix it.
If you can't fix it, take it apart and see how it "worked".
  Reply With Quote
Old 14th January 2004, 01:11 PM   #26
Banned
 
Join Date: Nov 2002
Location: Adelaide, Australia
Send a message via MSN to SkinnyBoy
Quote:
Originally posted by Matttcattt
could this amp run at +/-115vDC? if i take 230vAC mains, without a transformer, it would bhe easy to get this voltage.

please step away from the soldering iron...
  Reply With Quote
Old 14th January 2004, 01:14 PM   #27
diyAudio Member
 
Join Date: May 2001
Location: Bangalore, India
My take would be on bridging into a 4 ohm load at +-75 volt rails, each amp driving a 2 ohm load at 600 watts RMS. 1200 watts RMS into 4 ohms and over 2000 watts peak!
__________________
Sam
  Reply With Quote
Old 14th January 2004, 01:17 PM   #28
diyAudio Member
 
Workhorse's Avatar
 
Join Date: Dec 2004
Arrow Reply

CAUTIONirect mains Voltage related topic posting is prohibted on DIYAUDIO
IF u still insist on it then u can email me for further disscussion on mains voltage operation:amp_man_1@hotmail.com
  Reply With Quote
Old 14th January 2004, 01:23 PM   #29
Banned
 
Join Date: Nov 2002
Location: Adelaide, Australia
Send a message via MSN to SkinnyBoy
Default Re: Reply

Quote:
Originally posted by amp_man_1
CAUTIONirect mains Voltage related topic posting is prohibted on DIYAUDIO
IF u still insist on it then u can email me for further disscussion on mains voltage operation:amp_man_1@hotmail.com

really? cos you're messing with mains voltage anyway... and you have like 200 or more volts DC in some amps too...
  Reply With Quote
Old 14th January 2004, 01:30 PM   #30
diyAudio Member
 
Workhorse's Avatar
 
Join Date: Dec 2004
Arrow Reply

HEY MR JAYARAJ WHATS UR DECISION??
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Who has built their own? markp Solid State 43 3rd August 2014 10:10 AM
Hi! And I built one too... The RB Chip Amps 4 13th March 2009 10:12 AM
i built these a while ago and roystr Full Range 11 10th November 2005 01:49 PM
Anyone built this amp? JojoD818 Solid State 26 19th August 2003 12:32 PM


New To Site? Need Help?

All times are GMT. The time now is 10:29 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2