Primare 30.5 amp issue on power on - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th January 2014, 07:15 PM   #1
diyAudio Member
 
Join Date: Sep 2012
Default Primare 30.5 amp issue on power on

Hi i have Primare amp 30.5 and everything has been working great until resent days.

then i power up the amp i get the loud pop/click tru all the speakers connected.
like there if i would short speakers wires .
It also happens when i turn the amp off.

I tried disconnecting everything except the speakers from the amp and it still does it .

does anyone has any idea what causes that and how can i fix it . i will call repair shop and ask about it i just like to know if anyone has any ideas what has gone wrong

thank you
  Reply With Quote
Old 19th January 2014, 07:41 PM   #2
diyAudio Member
 
Join Date: Sep 2012
also beside the pop tru the speakers the amp works fine .
i can hear relay clicking when powering up and that's when i get the laud pop tru speakers
  Reply With Quote
Old 19th January 2014, 07:51 PM   #3
diyAudio Member
 
Join Date: Sep 2012
Click the image to open in full size.
  Reply With Quote
Old 19th January 2014, 07:52 PM   #4
diyAudio Member
 
Join Date: Sep 2012
Click the image to open in full size.
  Reply With Quote
Old 19th January 2014, 07:53 PM   #5
diyAudio Member
 
Join Date: Sep 2012
Click the image to open in full size.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regulated power supply using 30-0-30 EI core transforformer for Gaincore am dvijaydev46 Power Supplies 10 26th November 2013 05:33 PM
Low volume issue with Power Amp sergedc Solid State 6 28th July 2012 01:47 PM
DIY Jadis JA 30 power amp PCB first Tubes / Valves 0 11th January 2007 06:46 PM
2 x 500VA 30-0-30 Toroidal Power Transformers WALTER BURKHARD Swap Meet 4 30th July 2005 02:01 PM
MPA-30 power amp argo Solid State 0 10th March 2004 10:46 PM


New To Site? Need Help?

All times are GMT. The time now is 01:51 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2