Crown DC300A Repair/Restore - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th January 2014, 07:24 PM   #11
diyAudio Member
 
Join Date: Jan 2014
Location: New Hampshire
thanks Indianajo....will copy and place in my manual. Alot of good info there.
  Reply With Quote
Old 11th January 2014, 01:06 AM   #12
diyAudio Member
 
Join Date: Jan 2014
Location: New Hampshire
New nubs on power rocker switch. Now will machine two brass fasteners similar to what the OEM used. Will swage these to the steel bracket holding the rocker switch.
Attached Images
File Type: jpg 20140110_205948.jpg (405.4 KB, 269 views)
  Reply With Quote
Old 11th January 2014, 11:30 PM   #13
diyAudio Member
 
Join Date: Oct 2006
If you haven't read Tom Wait's DC300A rebuild thread yet, it could possibly be helpful in your efforts.
  Reply With Quote
Old 18th January 2014, 06:56 PM   #14
diyAudio Member
 
Join Date: Jan 2014
Location: New Hampshire
Power rocker switch is complete. The holes in the switch were opened to .110" which will accomodate #4-40 screws. The two holes in the metal bracket were threaded #4-40. The heads on the screws were reduced until they fit in to the counterbore. A 1" long screw works perfectly no shortening required. Switch operates and light works.

Initial power on confirms that channel 1 IOC light comes on and channel 2 operates as said by the previous owner. The channel 1 power board is missing the two driver transistors and two power transistors. Also missing two of the original transistor insulators. They are made out of a material that looks metallic. Does anybody have two of these available?
WThe four 2N6306 transistors to be used as driver transistors have been recieved.
Will start shopping for power output transistors MJ21194.
Can someone guide me through what checks can be made on the power board once it has been determined that the whole board is populated?
Attached Images
File Type: jpg 100_2863.JPG (851.8 KB, 240 views)

Last edited by rfitts46; 18th January 2014 at 07:01 PM.
  Reply With Quote
Old 18th January 2014, 08:01 PM   #15
diyAudio Member
 
Join Date: Jan 2014
Location: New Hampshire
missing R131 and R138 on cnannel 1 as well.
  Reply With Quote
Old 18th January 2014, 10:42 PM   #16
diyAudio Member
 
Join Date: Jan 2014
Location: New Hampshire
the non operating output board has a white wire coming from the DCA board that terminates at an emitter of an output transistor while the operating channel output board has this white wire going to the base of the driver transistor.
Attached Images
File Type: jpg marked up channel 1 power board from amp.jpg (661.5 KB, 219 views)
  Reply With Quote
Old 18th January 2014, 11:01 PM   #17
diyAudio Member
 
Join Date: Jan 2014
Location: New Hampshire
I am shopping for 20ea MJ21194 to be used as output transistors. If anybody has a set with same date code please send a response
  Reply With Quote
Old 19th January 2014, 02:21 AM   #18
diyAudio Member
 
jackinnj's Avatar
 
Join Date: Apr 2002
Location: Llanddewi Brefi, NJ
If you prefer, I have a few hundred MJ15003G matched.

one further thing I would do with the Crown DC-300 is bolster on more heat-sinking with aluminum fins.
  Reply With Quote
Old 19th January 2014, 11:43 AM   #19
diyAudio Member
 
Join Date: Jan 2014
Location: New Hampshire
This was off of T Waits thread on resurrecting a Crown DC300A, the15003 are seriously compromised at the supply voltages available from this amp. 21193 would be much better in the higher voltage region of SOAR. The extra current from the 15003 is of no advantage.
  Reply With Quote
Old 19th January 2014, 03:57 PM   #20
diyAudio Member
 
Join Date: Jan 2014
Location: New Hampshire
can I use NTE QW118-25 - 1/4W 180 OHM 2% Metal Resistor as a replacement for the carbon film resistors used as the driver base resistors on the power board?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Resurrecting a Crown DC300A TomWaits Solid State 473 23rd February 2014 07:18 AM
crown dc300a krmaudio Solid State 3 29th January 2010 08:54 PM
Crown DC300a Repair Questions DogStone Solid State 8 23rd November 2009 03:41 AM
Crown DC300A Sheggy Solid State 4 3rd July 2008 01:52 PM
Crown DC300A Please Vote! TomWaits Solid State 45 21st September 2006 07:18 PM


New To Site? Need Help?

All times are GMT. The time now is 10:38 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2