Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

NAD 325BEE will not turn on
NAD 325BEE will not turn on
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th October 2013, 09:00 PM   #1
brianc44 is offline brianc44
diyAudio Member
 
Join Date: Oct 2013
Default NAD 325BEE will not turn on

When I plug in my NAD 325BEE amp the yellow light on the front panel will turn on, but when I press the power button or use the remote, the amp will not power up. Using the remote, but not the power button, the yellow light will flash red and after I press the "on" button I am able to move the volume knob with the remote. However, the amp will still not power up (none of the lights turn on, speakers won't work.

Is there a fuse to replace, or an easy fix to try with this?
  Reply With Quote
Old 30th October 2013, 09:59 PM   #2
Ian Finch is offline Ian Finch  Australia
diyAudio Member
 
Join Date: Apr 2010
Location: Coffs Harbour
This is a protection fault. The protection circuitry is preventing you from operating the amplifier because:
The amplifier has a DC fault. (The output stage or servo has failed) or...
The protection circuit itself has a fault such as capacitor failure.
this has been found on several 3XX series NADs here before.

Logically, you need to fix the fault first before causing further damage by attempting to bypass the protection. Unfortunately, it's unlikely to be simple and you'll need a DMM, tools and the service manual for starters. The Service Manual has a troubleshooting guide that you can use to get the indications right, to begin with.
__________________
Ian
  Reply With Quote
Old 31st October 2013, 12:00 AM   #3
JonSnell Electronic is offline JonSnell Electronic  United Kingdom
diyAudio Member
 
JonSnell Electronic's Avatar
 
Join Date: Dec 2012
Location: The Jurassic Coast, England. GB
The set bias pots are a known problem as these amps age. It they get a poor connection/wiper intermittent, the bias control stops and the output transistors try and dissipate lots of current causing overload and protection.
__________________
Support for Fender, Marshall and all Valve Equipment; Audio Innovations, Audiorama FU29, Quad and Leak. www.jonsnell.co.uk
  Reply With Quote

Reply


NAD 325BEE will not turn onHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
NAD 3130 left channel dropping in and out as I turn the volume control was8v Solid State 2 1st July 2007 06:16 PM
SAE 2400 turn on/turn off pop Glen B Solid State 16 31st July 2006 01:32 AM


New To Site? Need Help?

All times are GMT. The time now is 10:37 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki