Newbie needs help with QSC MX700 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th October 2013, 03:34 AM   #1
diyAudio Member
 
Join Date: Dec 2011
Default Newbie needs help with QSC MX700

I have a QSC MX700 that has no output. I am relatively new to diagnosing amplifier problems so if someone has some patience and knowledge, I am willing to do the work. I can identify and test all the components on the board, just not sure how they come together to do what they do so I need some guidance.
Problem-no sound from either channel. I have checked voltage from transformer and have 96VAC on both sides. From the rectifier, I have 132VDC and if I am doing it right, I have no 15VDC coming out of my power supply. My VCC is 132VDC. I checked all the transistors with a diode tester and they all read the same so one could assume they are okay. All my caps read proper on my capacitor checker. Any help? Here is a link to the website that has the manual with a schematic for this unit. Thank you in advance.

http://media.qscaudio.com/pdfs/mx700man.pdf
  Reply With Quote
Old 20th October 2013, 05:31 AM   #2
djk is offline djk
diyAudio Member
 
djk's Avatar
 
Join Date: Feb 2001
Location: USA
The 15V zeners burn out on these, replace the opamps at the same time.
__________________
Candidates for the Darwin Award should not read this author.
  Reply With Quote
Old 31st October 2013, 09:31 PM   #3
diyAudio Member
 
Join Date: Dec 2011
This one turned out to be relatively easy. I followed the circuit along and found there was nothing after the thermal switches on the heat sink. Turned out to be bad solder joints on these and also at the two four pin connectors from the transformer. Went around and resoldered everything and now it works like a charm. One thing about getting older, need a bigger magnifying glass.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
QSC Repair SillySounds Solid State 6 23rd May 2013 07:17 AM
Unbalanced pc to balanced qsc mx700 erichthinks PC Based 1 26th June 2012 12:04 AM
QSC ISA 300Ti ($300) and two QSC CX4T ($150 each) problematica Swap Meet 0 12th November 2010 04:20 PM
newbie,QSC part substitutes sj9282,ne5532 javey Solid State 8 21st May 2007 06:55 PM


New To Site? Need Help?

All times are GMT. The time now is 03:12 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2