Amplifier troubles Plz Help - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th December 2003, 05:04 AM   #1
ReverB is offline ReverB  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Dc
Exclamation Amplifier troubles Plz Help

Ok here is the problem. I am working with a kicker zr-240. When i bought it i tested it and it was in perfect working order. Now after being stored for 3 months i hooked it up and it is all screwed up. The amp did get banged around once but it wasnt too bad.

When i hook up the amp it pushes it seems like a combination of dc and ac current( i havent had a chance to test it because i recently moved and misplaced equipment). when i am not messing with the input sens. it seems to push out ac current and the speaker flutters at about i would say 10-30 Hz. when i am tweaking the amps input sens. it moves the speaker with a dc current in relation to the adjustments to the imput pot. Ya there is some REALLY weird stuff going on here.


Does anyone have any suggestions?

I was thinking that it could have somthing to do with the input ground. The amps output circ. is working because it is driving the speaker and the power light is coming on. This amp also has a removable crossover that i have switched out with one from a working amp.


I have no clue can someone please point me out in the right direction


Thank you,
Aaron
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Amp. troubles PLZ HELP!!!! ReverB Car Audio 5 1st November 2009 01:11 AM
SW troubles... PIA nunayafb Multi-Way 7 30th March 2006 12:04 PM
transformer troubles please help troublecomes Parts 4 31st December 2005 11:40 AM
ZV5 Startup Troubles keenlyside Pass Labs 0 13th June 2005 06:35 AM
amp troubles squid6 Tubes / Valves 5 8th July 2004 06:50 AM


New To Site? Need Help?

All times are GMT. The time now is 03:27 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2