Help Sony TA-1055 goes ffttzz ftz crack CRACK! - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th June 2013, 10:24 PM   #1
Simon S is offline Simon S  England
diyAudio Member
 
Join Date: Sep 2010
Default Help Sony TA-1055 goes ffttzz ftz crack CRACK!

I bought this Sony TA-1055 (about 40 years old I think) recently and it has been sitting between a Lenco turntable and a pair of Spendor BC1s. Sounding very nice. Unfortunately it went ffttzz ftz crack CRACK. Turned the volume to zero but this made no difference. Turned it off as quickly as I could to avoid damaging the speakers. Can anybody tell me what this might be? Could this be a home repair for me? I can solder competently but I'm no electronics expert. If it is something like replacing capacitors, I could do that. I like this amp and would like to keep it (no money for another anyway!).

Any help welcome.

Simon.
  Reply With Quote
Old 27th June 2013, 11:42 PM   #2
diyAudio Member
 
Join Date: Jan 2010
You have problem between volume to speaker no pun intended. You can start to recap the small electrolytic caps ( not big filter caps) between volume to speaker to see if it addresses problem then you can do rest.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Question regarding my SONY TA 1055 spokes1979 Multi-Way 0 22nd March 2011 04:19 AM
Debugging a Sony TA-1055 oddbjorn Solid State 19 24th October 2010 11:24 AM
Sony ta-1055 issues Spytap Solid State 4 12th June 2010 05:20 AM
Sony TA-1055 transistors memobmw Power Supplies 0 24th February 2010 05:30 PM
sony TA 1055 LAO Solid State 1 30th August 2004 04:54 AM


New To Site? Need Help?

All times are GMT. The time now is 12:16 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2