I need help with mosfet circuit - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st June 2013, 05:19 PM   #1
rafjr00 is online now rafjr00  United States
diyAudio Member
 
Join Date: Jul 2009
Location: Pearl River
Default I need help with mosfet circuit

This is not a Pass design but I need help and this is THE place for mosfet.
I was given a MosFet 120, Dyna st-120 modded amp. It was designed and built by Frank Van Alstine. I contacted him at AC but this is one of his very early ones and he does not have anything on it.
I have all the pieces, according to the parts list, except for the PCBs.
Alex mm has been kind enough to offer his services in design new ones but has questions about the schematic as some things are not marked.
I can not express how thankful I would be if some of you would look over the schematic and offer your two cents.
Thank you,
Riki
Parts list
Schematic
  Reply With Quote
Old 2nd June 2013, 12:57 PM   #2
AndrewT is online now AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
How about moving this to solid state?
His "mosFET" excuse is not a valid reason to post in the Pass section.
__________________
regards Andrew T.
  Reply With Quote
Old 2nd June 2013, 01:13 PM   #3
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007


Moved to solid state forum.
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote
Old 2nd June 2013, 05:38 PM   #4
rafjr00 is online now rafjr00  United States
diyAudio Member
 
Join Date: Jul 2009
Location: Pearl River
No excuse Andrew,
Thanks for putting it in the right place.
  Reply With Quote
Old 2nd June 2013, 05:45 PM   #5
AndrewT is online now AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
I have waited for more than two minutes and image is not downloading.
The download is still waiting while I type this.
__________________
regards Andrew T.
  Reply With Quote
Old 2nd June 2013, 08:01 PM   #6
jaycee is offline jaycee  United Kingdom
diyAudio Member
 
Join Date: Apr 2004
Location: Norwich, UK
There wasn't much missing. Here's my best guess. I left out the regulator part as that's fairly obvious.
Attached Images
File Type: png jensen mosfet-120.png (22.4 KB, 198 views)
  Reply With Quote
Old 2nd June 2013, 11:03 PM   #7
rafjr00 is online now rafjr00  United States
diyAudio Member
 
Join Date: Jul 2009
Location: Pearl River
Not sure Andrew, just worked for me. :-(
Thanks Jaycee
Alex is working on the PCB layout for me.
Due either of you see anything out of place/not right/could be better?
Thanks

Last edited by rafjr00; 2nd June 2013 at 11:08 PM.
  Reply With Quote
Old 3rd June 2013, 02:40 AM   #8
jaycee is offline jaycee  United Kingdom
diyAudio Member
 
Join Date: Apr 2004
Location: Norwich, UK
I'd probably use a larger input cap C6, at least 1uF.
I think those gate resistors R11 and R12 are too large.
Add gate protection to the MOSFETS
Do away with the 1N914's - use LEDs perhaps.

I'm no expert with MOSEFTs though to be honest. Is there any reason for making this particular circuit?
  Reply With Quote
Old 3rd June 2013, 03:42 AM   #9
rafjr00 is online now rafjr00  United States
diyAudio Member
 
Join Date: Jul 2009
Location: Pearl River
I just wanted to put the amp back together, but I am not a stickier for keeping it true to the schematic.
Should I start with the same number of LEDs as 914s?
  Reply With Quote
Old 3rd June 2013, 09:26 AM   #10
jaycee is offline jaycee  United Kingdom
diyAudio Member
 
Join Date: Apr 2004
Location: Norwich, UK
No, the 1N914 drops 1V, a red LED is about 1.7V, green typically 2V. I'm wondering why they didnt use a 5.1V zener instead of all those diodes - noise perhaps.

I can't find anything about Q2 except that it was a small MOSFET.... otherwise i'd try and simulate the circuit
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Class Mosfet power amplifier circuit Agus Widarto Pass Labs 16 18th February 2008 05:06 PM
bias circuit for mosfet help AudioGeek Solid State 2 30th April 2006 12:22 AM
Will this MOSFET-driver circuit work? Danko Power Supplies 7 24th June 2005 03:09 PM
short-circuit protection in mosfet's amp...?? csl113 Solid State 8 31st January 2005 07:10 PM
MOSFET equivalent circuit nobody special Solid State 1 13th February 2003 07:12 PM


New To Site? Need Help?

All times are GMT. The time now is 03:21 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2