Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th April 2013, 06:47 PM   #1
diyAudio Member
 
Join Date: Oct 2005
Default Leach LMF-1 dead channel

One channel is distorting on my Leach LNF-1 amp. I took it apart and found one electrolytic capacitor was discolored. I replace the cap with the another electrolytic that was in series with the problem cap. This did not fix the problem my question is :
1. Is there anyone out there that has experience with this circuit and any suggestions where to look next?
2. Do you know anyone that repairs this amp? I tried to contact some repair shops in the Boston area with no luck.

Just for reference the C9 150uf and C7 35uf was replaced as per Electronic One Inc drawing.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Left channel dead doubled Solid State 10 11th April 2010 11:19 AM
Dead Channel - Charlize 2 st_eloi Class D 0 17th January 2010 08:46 PM
Amplifer 1 channel dead .Please help Pass lover Solid State 9 14th November 2009 12:35 AM
Dead channel Carlp Tubes / Valves 15 1st February 2007 03:54 AM
ADC LMF-2 tonearm mounting info Herb1 Analogue Source 12 8th October 2005 05:39 AM


New To Site? Need Help?

All times are GMT. The time now is 01:53 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2