Silence from my amp - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd April 2013, 09:26 PM   #1
K12pfc is offline K12pfc  United Kingdom
diyAudio Member
 
Join Date: Apr 2013
Default Silence from my amp

Hi this is my first post here so be gentle, I got a fairly old but brilliant technics system with the amp model no. SA GX100L, today whilst playing it the sound suddenly stopped, all lights were on so not a power problem, anyway 2 things come to my mind, overheating, I have a nasty habit of leaving he system on, it's been on now over a week! Or could it be speaker protection circuit, I just put 2 speakers from a mini system onto the amp, could this cause the problem. Be gentle.
  Reply With Quote
Old 25th April 2013, 09:41 AM   #2
diyAudio Member
 
east electronics's Avatar
 
Join Date: Jan 2006
Location: Athens GREECE
the info provided is too little for an effective answer
Does the relay click ?
did you check the basics IE fuses or so ?
The specific amp is IC based which usually is 1-0 situation IE IC is gone
A Tape monitor switch that is pressed or dirty might also stop the sound

check the basics
__________________
SERVICE ΕΝΙΣΧΥΤΩΝ ΚΑΙ ΙΑΠΩΝΙΚΩΝ ΜΗΧΑΝΗΜΑΤΩΝ ΗΧΟΥ www.eastelectronics.gr
  Reply With Quote
Old 25th April 2013, 11:00 AM   #3
Komiyan is offline Komiyan  Australia
diyAudio Member
 
Join Date: Apr 2013
What is the impedance of the speakers?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
re "The sound of silence" jez Solid State 7 16th October 2014 10:43 PM
Ringing in ears when silence due to power failure gmphadte The Lounge 20 21st February 2012 08:45 AM
Two moments of silence please wa2ise The Lounge 1 13th September 2011 03:29 AM
Aaaargh silence from my Arcam CD player skenwrick Digital Source 9 7th January 2006 12:12 AM
Silence audio o/p bimbla Analogue Source 5 4th February 2003 07:06 PM


New To Site? Need Help?

All times are GMT. The time now is 10:42 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2