Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th February 2013, 08:32 PM   #1
diyAudio Member
 
Join Date: Feb 2012
Default Help with Arcam Delta 110 pre

Picked one of these up for cheap today. The line level inputs sound amazing! Parts connexion upgraded some of the important op-amps and put blackgates in crucial locations. Two problems though, the left channel is dead in the phono input (bad opamps?) and there is way too much hiss in the right channel of the digital inputs (noisy transistors or op amp or both?). I'll post some pictures of the boards and want to see what yall think. I will probably need some help sourcing the transistors and op amps. If anyone has any service info to pass alot it would make this a lot easier!

Assuming the analog section is at the bottom? which one would be the right side?
Click the image to open in full size.

Should be able to replace the op amps in the bad channel if I can source them
Click the image to open in full size.
  Reply With Quote
Old 10th February 2013, 08:54 PM   #2
diyAudio Member
 
indianajo's Avatar
 
Join Date: Jan 2010
Location: Jeffersonville, Indiana USA
How old is this? That big S on the op amps used to be the Signetics trademark, back in the dark ages. They were bought up decades ago. I see a 90 date on the Adcom 24 leg IC. Over 20 years of age, all those electrolytic capacitors with the + near one lead are suspect. They are aluminum cans full of water slime, sealed with rubber. Old rubber is dirt. The little orange one with a + is a tantalum electrolytic cap, also a short lived phenomenon in all the gear I own. I've had new tantalum caps with popcorn noise, a perplexing problem for 15 years until I replaced them with CPO ceramic caps. Mark the PWB with a sharpie before changing the electrolytic caps, if you put them in backwards they pop open and leak.
Do you own a DVM? you should be able to answer questions like which side is which channel by tracing the wires. All the defective op amps I've found, were blown up by rampant rail voltage blasting in from failed output transistors.
Extreme hiss can also be caused by bad solder joints. Low levels can be caused by resistors over 100kohms in high gain circuits. Carbon comp is standard hiss, metal film resistors are lower in hiss.
You can get the schematics on these IC's from datasheetcatalog.com, probably.
__________________
Dynakit ST70, ST120, PAS2,Hammond H182(2 ea),H112,A100,10-82TC,Peavey CS800S,1.3K, SP2-XT's, T-300 HF Proj's, Steinway console, Herald RA88a mixer, Wurlitzer 4500, 4300

Last edited by indianajo; 10th February 2013 at 09:10 PM.
  Reply With Quote
Old 10th February 2013, 09:01 PM   #3
diyAudio Member
 
Join Date: Feb 2012
I think it is about 20 years old. I understand the electrolytics probably need replacing, but first concern is getting these two things working. If I'm getting no sound on the left channel from the phono input, would the opamps being shot in that channel be a good starting point? I understand what you are saying about tracing the channel with a DMM, but how would I do that with a digital signal?
  Reply With Quote
Old 10th February 2013, 09:38 PM   #4
diyAudio Member
 
indianajo's Avatar
 
Join Date: Jan 2010
Location: Jeffersonville, Indiana USA
Quote:
Originally Posted by downhiller2010 View Post
I think it is about 20 years old. I understand the electrolytics probably need replacing, but first concern is getting these two things working. If I'm getting no sound on the left channel from the phono input, would the opamps being shot in that channel be a good starting point? I understand what you are saying about tracing the channel with a DMM, but how would I do that with a digital signal?
No.
the only thing I have noticed about 20 year old op amps, is that the ones that have been to sea, the legs rust off.
I suggest you trace DC voltages with a DMM. DMM's are useless for audio signals not at 60 or 50 hz. All the ones I've owned or been loaned from work. Besides electrolytic caps and power supplies, connections at less than 25 VDC and 50 ma tend to to oxidize and become high resistance. Removing and replacing such connections is a good start at cleaning them. Else, erasers and alcohol.
To help trace, datasheets on op amps and common IC's are on datasheetcatalog.com.
__________________
Dynakit ST70, ST120, PAS2,Hammond H182(2 ea),H112,A100,10-82TC,Peavey CS800S,1.3K, SP2-XT's, T-300 HF Proj's, Steinway console, Herald RA88a mixer, Wurlitzer 4500, 4300
  Reply With Quote
Old 10th February 2013, 09:52 PM   #5
diyAudio Member
 
Join Date: Feb 2012
I'll have to see what I can dig up, I may be getting in over my head on this one.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Arcam Delta 290 lduarte1973 Solid State 35 16th October 2013 04:42 PM
Delta 290 Arcam mike salway Solid State 0 17th September 2005 03:03 PM
Arcam Delta 70.2 drive Mike McMahon Digital Source 34 20th April 2005 02:22 PM
Arcam Delta 70.2 Rotellian Digital Source 2 16th January 2004 10:33 PM


New To Site? Need Help?

All times are GMT. The time now is 12:11 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2