organ amp power on noise - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th February 2013, 11:33 PM   #1
diyAudio Member
 
Join Date: Aug 2010
Location: baton rouge, La
Default organ amp power on noise

Forum
I liberated the amplifiers from a Saville solid state organ, which consists of 5 groups of 6, 20w amplifiers for a total of 30, 20w amplifiers. The power supply is seperate and voltage for the amps is 47v dc.
For testing I have one stereo amp pair connected up with the PSU and speakers. When the power is turned on, a loud fixed pitch sound is heard, which collapses over 3-4 seconds, then every thing quiet, and works well. I tried turning on the PSU first then the amps, but same result.
The PSU is typical old style metal chassis with transformer on top, full wave bridge.
The amps are open with a plate heat sink covering most of the PCB, no overall metal case or enclosure. Connection from PSU to AMP is two wire +/-, 47vdc.
The settup mimics the original setup when in the organ.
Any suggestions on how to prevent the initial noise?
Tuneturkey
  Reply With Quote
Old 10th February 2013, 02:14 AM   #2
diyAudio Member
 
Join Date: Jan 2011
Location: Fosser, Aurskog-Holand, Akershus, Norway.
Often caused by dry caps.
But is this on all amps?
__________________
Sooner or later you end up with TANDBERG
  Reply With Quote
Old 10th February 2013, 02:40 PM   #3
diyAudio Member
 
Join Date: Aug 2010
Location: baton rouge, La
Default organ amp power on noise

Yes, its the same for all 5 of the amps on the same PCB, thats why i tend toward a power supply problem.
Do you think that it is a PSU filter cap? The capacitor is slow to charge up so the 60 hz ripple stays high until it finally charges up. makes sense!
Thanks,
tuneturkey
  Reply With Quote
Old 10th February 2013, 09:36 PM   #4
diyAudio Member
 
indianajo's Avatar
 
Join Date: Jan 2010
Location: Jeffersonville, Indiana USA
I don't usually start debugging a defective amp until all electrolytic caps are under 20 years old. Then if I still have problems, i get out the meter or scope and start looking for the problem. Usually I check DC voltages against the schematic, but lacking that. you can check your power supply voltages at 80% of what the capacitor rating is. Then check the b-e junction of the offending transistor that is about 0.6. Then if you still have oscillation not at 60 or 120 hz, use a scope or VOM or VTVM to track it down to a particular component. You have to put a .47 uf or .1 uf capacitor in series with the probe of a VOM to check AC, they read DC voltages on the AC scale otherwise. VTVM's come with a "RF" probe with a capacitor inside. A DVM is useless for tracking AC signals at non-power line frequencies. At least all the DVMs I have bought. A VOM, you can figure out the frequency of the oscillation with smaller and smaller series capacitors. Amps can have inaudible oscillations, too.
What are you going to use 30 20W amps for? I can't imagine you have a hall with 30 speakers in it. That arrangement was useful for multi-reflections of one oscillator organ sounds, but not much else IMHO.
See this about setting the bias current: vintage amplifier repair/upgrade manual
__________________
Dynakit ST70, ST120, PAS2,Hammond H182(2 ea),H112,A100,10-82TC,Peavey CS800S,1.3K, SP2-XT's, T-300 HF Proj's, Steinway console, Herald RA88a mixer, Wurlitzer 4500, 4300

Last edited by indianajo; 10th February 2013 at 09:38 PM.
  Reply With Quote
Old 10th February 2013, 10:16 PM   #5
diyAudio Member
 
Join Date: Aug 2010
Location: baton rouge, La
Indianago,
Well, I liberated everything from the organ that I could get off; amps, SAMS, powersupply, keyboards, everything but the wood console.
I am into Virtual , VTO, electronic organs and will use six of the amps with a delta 1011 soundcard on my theatre organ, and am midifying a moller console, modified to the horseshoe arrangement.
The Savile organ was based on the principal that there should be one amp for each 2, consecutive, notes, since adjacent notes are seldom if ever played at the same time. to go further, each amp powered a speaker mounted on a helmholtz resonator, a cardboard tube of diameter and length to match the frequency of the note pair,.With a dedicated speaker mounted on the end. Yes, there were 30 tubes with speakers from very small up to 15" speakers mounted on large tubes. Took a lot of space. It worked very well, with good blending of overtones, since the speakers played only one note. now you know!
I have in my possession a Dynakit ST 120, dual 60 watt amp which has been quiet for some time, but would love to have it playing to driver subwoofers for the 16' pedal notes. As I recall it was good down to 20hz with little rolloff. Do you do amp repair, etc.? i see from the list of equipment below your email that famous work Wurlitzer. whats the connection?
back to my original post, Would you start with the PSU filter caps, since the noise is common to multiple amps/
Thanks for the help!
Tuneturkey (in Baton Rouge, LA)
  Reply With Quote
Old 10th February 2013, 10:59 PM   #6
diyAudio Member
 
indianajo's Avatar
 
Join Date: Jan 2010
Location: Jeffersonville, Indiana USA
There was a thread about the Saville organ on organforum.com recently. Lots of people liked the sound.
Like I say, save time, replace all e-caps and clean connectors first. Then if oscillations remain, check all carbon comp resistors at actual value (they change). If that doesn't do it, then drag out the scope or VOM to trace remaining oscillations or other problems.
My adventures with the dynakit ST120 are detailed in here: Dynaco Stereo 120...can be beautiful
I handbuilt the 7 transistor djoffe design bias boards for the ST120 on perfboard that got rid of the cold crossover distortion, and love the improved sound. He won't sell PWB's of that mod, so making a good ST120 is not really economic at over $2 an hour. I also handbuilt the dual fan contraption that keeps it from melting the solder off the output caps if run to long at 10 W/ch (big fireball at church under the lectern). Djoffe is selling a ST120 - LM3886 IC conversion board on updatemydynaco.com, that shotguns all the old parts but leaves the heat problem to the user. His heatsink has no fins or fan, thus is good only for a limited time at wattage IMHO. If I were going into the business, I'd put one commercial finned heatsink crossways in the ST120, and one fan with a thermostat. My 2 fans on the ST120 run all the time, and if it wasn't behind the couch and I wasn't hard of hearing it might be annoying . However, heat and distortion problems are gone, I ran the ST120 17 hours a day for 18 months until I kicked the bias board in December and broke something. Should have put the top on. Got a PV-1.3k all over the coffee table, trying to invent a speaker protection circuit that actually does that instead of burning the lands off the PWB as previously designed.
The Wurlitzers were highly recommended by Paul0557 on organforum, are waiting complete re-e-cap. The 4500 whimpers a little, the 4300 makes a low moan without any keys down. At least they have hard key contacts at 170 Vdc. The main functional organ now is the Hammond H182 with the smashed case. 71 new e caps and some tab and drawbar cleaning really pepped up the sound on that. Was trying to play the H182 last night. I have poor pedal accuracy, still.
__________________
Dynakit ST70, ST120, PAS2,Hammond H182(2 ea),H112,A100,10-82TC,Peavey CS800S,1.3K, SP2-XT's, T-300 HF Proj's, Steinway console, Herald RA88a mixer, Wurlitzer 4500, 4300
  Reply With Quote
Old 10th March 2013, 01:01 AM   #7
diyAudio Member
 
Join Date: Aug 2010
Location: baton rouge, La
Question;
I have two 300w solid state amps, purchased on ebay, raw pcb with heat sink, no power supply. The amps were supposedly made by or for Acoustic Research, but have no labels, markings or other identification numbers. Are you aware of any such vendor? I have not attempted to power up since i don't know voltage or amp requirement. I will pull some data off the pcbs and add them to this thread. Possibly you can help me determine enough to get them running.
Thanks,
tuneturkey
  Reply With Quote
Old 10th March 2013, 01:30 AM   #8
diyAudio Member
 
indianajo's Avatar
 
Join Date: Jan 2010
Location: Jeffersonville, Indiana USA
If the power transistors have industry part numbers on them, you can download the datasheet from datasheetcatalog.com usually, and figure out what voltage they can run at. If the Vceo is a 10 ma spec, you can run PS rails about 1/2 that, but if the Vceo is a 50 ma spec, you need to run PS rails about 1/3 to 1/4 of that.
If the output transistors have private numbers, sometimes you can determine what they are by what date is on the capacitors etc. There are fads in transistors where everybody uses the same thing because it is the cheapest. How many output transistor pairs kind of determines how they did the 300 w spec. Current (I^2)*R is the power of a channel, and R is typically 8 ohms up to 1980 and 4 ohms after about 1980. If the amp is a car amp, the designed speaker resistance is 2 ohms or 1 ohm. The highest voltage capacitor on the PWB will tell you something about what service it was intended for.
I drew my own schematic diagram for the ST120 when I first repaired it, because there was no internet or other resource outside the Ham Radio club (and I don't talk enough to be a ham.) I would suggest you do this.
Acoustic Research was a speaker company in 1970 when I was buying speakers, and made a famous turntable. Then they went bankrupt, the name was sold somewhere, and like Dual (that was originally a turntable company) the logo might show up on anything, mostly imported. I didn't like their speakers much, too many watts consumed, not enough sound out.
If your output transistors have C#### or A#### on them, they are really 2SC#### or 2A####, because the Japanese found putting the first two letters on the part too expensive for words.
If you still want to silence your Saville organ amps. and the caps are new and the resistors are in spec, draw out a schematic and think about putting a power up reset circuit on it. My Peavey PV-1.3k amp has an input silence circuit that has an electrolytic cap timer (one junction transistor) that uses a jfet transistor to short the input to the power supply until the capacitor charges up. Schematic is on eserviceinfo.com, but this circuit is mainly for devices that have an op amp in the first stage.
__________________
Dynakit ST70, ST120, PAS2,Hammond H182(2 ea),H112,A100,10-82TC,Peavey CS800S,1.3K, SP2-XT's, T-300 HF Proj's, Steinway console, Herald RA88a mixer, Wurlitzer 4500, 4300

Last edited by indianajo; 10th March 2013 at 01:35 AM.
  Reply With Quote
Old 10th March 2013, 10:43 PM   #9
diyAudio Member
 
Join Date: Aug 2010
Location: baton rouge, La
Ok - The unit has 5 ea MJ15024 (TO220) lined up on the left end of the sink and 5 ea MJ15025 on the right side. the leads extend thru the sink (1/4"thk) and on to the PCB. In the middle of the sink are three smaller transistors, a C168 on left, C158 middle and A958 on right. There are 2 small heat sink, 2"x2"x2', on left sitting on flatback transistors on the PCB. Also are 2 pair of transistors (T05) size. Electrolytics on the PCB are rated 100V. I have a photo of the unit, bu can't insert it. if i can find your email address, i'll send. Evidently, the PS capacitors were bolted in to the PCB, 4 each total , probably 3" in dia. The left end of the board has two plug on terminals labled LS1 and gnd , same on the other end. There is a 3 pin female connector on the component side of the board, and 2 on the back side, one 3 pin, one 4 pin.
Thanks,
Tuneturkey
  Reply With Quote
Old 11th March 2013, 01:15 PM   #10
diyAudio Member
 
indianajo's Avatar
 
Join Date: Jan 2010
Location: Jeffersonville, Indiana USA
This sounds fairly powerful. MJ15024 and 25 were TO3 steel case parts, according to recent datasheets. I thought Motorola TO247 (plastic, bigger than TO220) parts were prefixed MJL and MJW. Anyway, if the parts aren't counterfeit, you should be able to use +-75 to +-85v rails. If you are going to use that much, your speakers should be capable of half the rail voltage.
For 300 watts at 4 ohms you would need 8.7 amps at 34.7 volts. That would mean a power transformer of +-70 v rails. If your speakers are not that power capable, you can use lower power supply voltages.
The 2SA968 was in the Peavey PV-1.3k I just repaired, so the design time of this amp was about 1994.
For that much current you probably need at least 4700 uf @ 80v capacitors. The PV-1.3k has 10000 uf capacitors. I just bought some nice US assembled Panasonic 4700 uf 80 v ones from Newark.com rated 3000 hours life @ 85 deg c, ECO-S2AP472DA. You'll have to build a little board to strain releive the wires you solder to the snap in cap terminals. I use 1/16" or 1/8" thick LE laminate from mcmaster.com, which I can saw up with a sabre saw and drill with ordinary HS steel bits.
Whether your power transformer needs single 17 a winding or dual 8.6 a windings depends on whether this is a flying rail amp like the Peavey designs, or emitters and emitter resistors are connected to the speaker hot like more conventional designs. The conventional designs can use a single winding transformer.
Altenative to the power transformer/rectifier idea, you could buy a switching power supply. audiopower of italy was promoting their dps-400 400 W model on power supplies. and connexelectronic in hong-kong has his own section of the vendors forum below on diyaudio. These switching supplies would have to be in their own ventilated steel box to keep the howl out of the audio part, IMHO. Peavey put the switcher power supply in a separate steel box in the CS800s, I own one.
__________________
Dynakit ST70, ST120, PAS2,Hammond H182(2 ea),H112,A100,10-82TC,Peavey CS800S,1.3K, SP2-XT's, T-300 HF Proj's, Steinway console, Herald RA88a mixer, Wurlitzer 4500, 4300

Last edited by indianajo; 11th March 2013 at 01:31 PM.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Conn Organ Post Amp to Power Amp Question Hamman Solid State 7 25th July 2012 07:20 PM
Sure amp in car, thump/noise on power up majorahole Chip Amps 6 14th July 2011 03:03 PM
Tube power amp noise problem pelanj Tubes / Valves 12 1st July 2009 01:28 PM
PassAleph 3 power amp with hum noise, please help Pass lover Pass Labs 18 19th May 2009 03:17 PM
Use power semi as low noise amp? Circlotron Solid State 0 4th July 2002 05:19 AM


New To Site? Need Help?

All times are GMT. The time now is 02:12 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2