ESP P68 Subwoofer Amplifier - Need Help - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd February 2013, 04:19 PM   #11
diyAudio Member
 
Join Date: Apr 2012
Extra Heatsink out, now it gets warm

voltage drop: D2=656mv D3=648

are you sure about this 550mv? ou the build article says it should be between 30mv and 80mv, and yes, i messed up Q1,2,3 are BC546, Q4 MJE340 Q5,Q6 MJE350

Q7 and Q8 are in the main heatsink, and it says that Q1 to Q3 could be BC46 ou MPSA42, just to watch out the pins, since the are inverted, the silkscreen on the board are for the BC546

Quote from the build article:

Quote:
Note that if you use MPSA42 devices (and some other common variants), the pinouts are reversed! This means that the PCB overlay is not correct for these devices, so take great care when installing to make certain that you have the correct orientation.
Base Emiter: Q1 = 53V Q2 = 53V

Between terminals: R5 = 20mv R6 = 720mv R7 = 1350mv R16/17 = 210mv

and i'm using a standard green led

Last edited by PedroDeMio; 3rd February 2013 at 04:25 PM.
  Reply With Quote
Old 3rd February 2013, 04:58 PM   #12
jaycee is offline jaycee  United Kingdom
diyAudio Member
 
Join Date: Apr 2004
Location: Norwich, UK
The MJE340/350 is a very poor driver. Is there any reason you cannot use the specified MJE15032/3 devices?
  Reply With Quote
Old 3rd February 2013, 05:06 PM   #13
diyAudio Member
 
Join Date: Apr 2012
i can try, could this be the problem?

i want to be sure becouse the board has damages becouse the lops of replacements i've made, each time i'ts harder to remove the component without damaging the board

Last edited by PedroDeMio; 3rd February 2013 at 05:14 PM.
  Reply With Quote
Old 3rd February 2013, 05:51 PM   #14
diyAudio Member
 
Join Date: Apr 2012
to be sure, cracked open one off the transistors, i think i'ts ok

Click the image to open in full size.
  Reply With Quote
Old 4th February 2013, 05:30 PM   #15
diyAudio Member
 
Join Date: Apr 2012
another test, with a pre amp and gain of 14db, made just little diference
  Reply With Quote
Old 9th February 2013, 03:14 PM   #16
diyAudio Member
 
Join Date: Apr 2012
Everything works now, it was a wrong value resistor and a cracked track due the lots of components replace i made

the amps is amazing, strongly recommended

Cheers

Pedro
  Reply With Quote
Old 8th June 2013, 09:13 AM   #17
pallab is offline pallab  India
diyAudio Member
 
Join Date: Jul 2011
Location: kolkata,w.b,india.
hey i have 8 pair 2sc3858/2sa1494 sanken..sir,is their any problem if i use this instead of mjls in esp 68 project???help me....nd i have also 2 car subwoofer each 4 ohms..if i use 40 0 40v 800va transfomer for esp 68 nd connect it into 2ohms load (2 sub connect in parallel).is there any problem??
  Reply With Quote
Old 23rd June 2013, 05:15 PM   #18
diyAudio Member
 
Join Date: Apr 2012
Quote:
Originally Posted by pallab View Post
hey i have 8 pair 2sc3858/2sa1494 sanken..sir,is their any problem if i use this instead of mjls in esp 68 project???help me....nd i have also 2 car subwoofer each 4 ohms..if i use 40 0 40v 800va transfomer for esp 68 nd connect it into 2ohms load (2 sub connect in parallel).is there any problem??
That i don't know, but 2ohms is too low, will overheat/burn output transistors
  Reply With Quote
Old 23rd June 2013, 07:24 PM   #19
amptech is offline amptech  Scotland
diyAudio Member
 
Join Date: Jan 2009
Location: Glasgow
Send a message via MSN to amptech
Default p68 sub..

Quote:
Originally Posted by PedroDeMio View Post
That i don't know, but 2ohms is too low, will overheat/burn output transistors

This amp is not for 2 ohms use 4 ohms only...make sure its well cooled in use as it will heat up.
  Reply With Quote
Old 25th October 2013, 06:40 AM   #20
adey is offline adey  India
diyAudio Member
 
Join Date: Dec 2009
can i see the copper side of this pcb?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
esp P68 mods lance06 Solid State 3 24th August 2010 01:12 PM
C1 for the ESP P68 leander Solid State 6 8th November 2005 06:14 AM
ESP p68 subwoofer amp FS jeff2747 Swap Meet 0 12th January 2005 07:09 AM
ESP P68 and P3A kinser Solid State 2 3rd December 2004 01:22 AM
Help please Sub Amp P68 from ESP Greg F Chip Amps 3 13th October 2004 12:11 AM


New To Site? Need Help?

All times are GMT. The time now is 08:12 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2