JVC JR-S400 No power - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th January 2013, 01:54 AM   #1
diyAudio Member
 
Join Date: Apr 2005
Location: Simcoe Ont
Default JVC JR-S400 No power

I have a JVC JR-S400. It appears to be dead. I am a novice and it looks like a jungle in there. Any hints or tips would be greatly appeciated. The transformer primaries are good. I can tell my the draw when I engage the main power switch.
  Reply With Quote
Old 18th June 2014, 04:28 PM   #2
diyAudio Member
 
Join Date: Jun 2014
Thank you so much great helpful
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
JVC TT71/JVC QL-7 quality and price Kjeldsen Analogue Source 0 25th September 2012 07:25 AM
JVC VN700 power off problem starks Solid State 3 10th May 2012 05:01 PM
JVC JR s600 blows 8 amp fuses. srinath Solid State 15 7th February 2011 02:57 AM
jvc receiver jr-s301 adason Solid State 3 1st June 2007 11:53 PM
JVC M-3030 power amp schematic? mikeks Solid State 8 2nd September 2006 12:17 AM


New To Site? Need Help?

All times are GMT. The time now is 06:32 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2