Cyrus Two not working - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th January 2013, 02:02 PM   #1
diyAudio Member
 
Join Date: Jan 2013
Default Cyrus Two not working

Hi all
A few years ago I bought a second hand Cyrus 2 and PSX for my neighbour - all has been fine including reconnecting the set up at his new house...since last week there is no sound on any input.. He is using an iPod on a dock and a cd player...no sound on any input. There is a click in the speakers when disconnecting inputs on low volume but no sound when touching any of the phono plugs.

Both lights are on on the amp and PSX. I haven't tried opening up the amp and cleaning the volume and input switches.

Any advice?

Many thanks
Mike
  Reply With Quote
Old 13th January 2013, 02:59 PM   #2
diyAudio Member
 
Join Date: Jan 2011
Location: Fosser, Aurskog-Holand, Akershus, Norway.
Click in the speakers when switching off tells us the powerAmp is OK.
I am not sure, but i believe the two fuses inside both are for the power amp, 1,5A or so, aren't they?
But You might try to check them anyway.

Else there isn't much to check if You aren't trained in electronics to fix.
__________________
Sooner or later you end up with TANDBERG
  Reply With Quote
Old 13th January 2013, 03:24 PM   #3
diyAudio Member
 
Join Date: Jan 2013
No click when switching off ...I will check the inner fuses althoughbibbelievevthe Cyrus 2 won't have them installed as its being used with the PSX? Mike
  Reply With Quote
Old 13th January 2013, 04:52 PM   #4
diyAudio Member
 
Join Date: Apr 2010
Location: Coffs Harbour
Quote:
Originally Posted by Mikechaj View Post
No click when switching off ...I will check the inner fuses althoughbibbelievevthe Cyrus 2 won't have them installed as its being used with the PSX? Mike
Before guessing and pulling things apart without knowing what to search for, remove all input and output leads and measure the voltage between the output terminals to get an indication whether either amplifier is damaged or not. Get a DMM and set it to volts DC, using autorange or starting at 200V and working down until you get a stable reading which should be no more than 40mV.

You may only have a problem with the preamp and that will be less of a difficulty. Also, check out the many Cyrus 2 problem threads already here, with the search button, top of page.
__________________
Ian

Last edited by Ian Finch; 13th January 2013 at 04:54 PM.
  Reply With Quote
Old 13th January 2013, 10:20 PM   #5
ftpols is offline ftpols  Japan
diyAudio Member
 
Join Date: Dec 2012
Location: Yokohama, Japan
Default Cyrus Two not working

The Cyrus isn't set up correctly ("Both lights are on on the amp and PSX."). You need to open the Cyrus II and remove the two on board fuses if you you are going to power it from the PSX. Connect the power cable to the PSX and the umbilical from the PSX to the Cyrus II. Then when you power on the PSX only the PSX power lamp will light.

But first of all, try connecting the power cord to the Cyrus II with the fuses installed in the Cyrus II. Then remove the power cord and onboard fuses and hook up the PSX as explained above. That might give you a clue as to which unit is faulty. The next step is to troubleshoot the defect as suggested by Ian Finch.

PS. Before I start testing or replacing parts, I always disconnect the power supply and press the power switch for about 20 seconds to discharge the capacitors.

Best of luck. It's a great amp and worth repairing.
  Reply With Quote
Old 15th January 2013, 03:19 AM   #6
diyAudio Member
 
Join Date: Apr 2010
Location: Coffs Harbour
Since the amplifier was working (presumably with the PSX fitted) for your neighbour, I guessed the fuse issue was eliminated. So, any news Mikechaj? Problem solved?
__________________
Ian

Last edited by Ian Finch; 15th January 2013 at 03:21 AM.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP, repaire Cyrus LFAU similar to Cyrus II ccheung Solid State 12 5th June 2012 09:12 AM
Cyrus 3 / Cyrus III amp help contax Solid State 12 23rd October 2010 01:53 AM
Wanted working Cyrus II + PSX Tazzer9999 Swap Meet 1 26th October 2009 06:44 PM
WTB Cyrus 1 or Cyrus 2 amplifier monstertrucker Swap Meet 0 20th November 2008 01:04 AM
WTB Krell KSA Mk2- working or non working Jozua Swap Meet 0 20th March 2006 11:14 AM


New To Site? Need Help?

All times are GMT. The time now is 08:55 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2